はじめに
CCNAを受験するにあたって、実際にコマンドを打って構築をすることが大切らしい。
Cisco Packet Tracerを使用して構築の練習とその流れ、結果を示して、気づいたことなどをまとめていこうと思う。
目標
- OSPFを使用してダイナミックルーティングを実装する。
- マルチエリアの構成も構築してみる。
- 実際に障害を起こしてみてどうなるか見てみる。
実践
1. シングルエリアOSPF
Router0(config)#interface fa 0/1
Router0(config-if)#ip address 192.168.1.1 255.255.255.0
Router0(config-if)#no shutdown
Router0(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
Router0(config-if)#exit
Router0(config)#interface fa 0/0
Router0(config-if)#ip address 192.168.10.1 255.255.255.0
Router0(config-if)#no shutdown
Router0(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
Router0(config-if)#exit
//OSPF setting
Router0(config)#
Router0(config)#router ospf 1
Router0(config-router)#network 192.168.10.1 0.0.0.0 area 0
Router0(config-router)#network 192.168.1.1 0.0.0.0 area 0
//確認
Router0#show ip route
~略~
Gateway of last resort is not set
C 192.168.1.0/24 is directly connected, FastEthernet0/1
O 192.168.2.0/24 [110/2] via 192.168.10.2, 00:00:06, FastEthernet0/0
C 192.168.10.0/24 is directly connected, FastEthernet0/0
Router0#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
192.168.10.2 1 FULL/DR 00:00:39 192.168.10.2 FastEthernet0/0
Router1(config)#interface fa 0/1
Router1(config-if)#ip address 192.168.2.1 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
Router1(config-if)#exit
Router1(config)#interface fa 0/0
Router1(config-if)#ip address 192.168.10.2 255.255.255.0
Router1(config-if)#no shutdown
Router1(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router1(config-if)#exit
//OSPF setting
Router1(config)#
Router1(config)#router ospf 1
Router1(config-router)#network 192.168.10.2 0.0.0.0 area 0
Router1(config-router)#network 192.168.2.1 0.0.0.0 area 0
//確認
Router1#show ip route
~略~
Gateway of last resort is not set
O 192.168.1.0/24 [110/2] via 192.168.10.1, 00:13:10, FastEthernet0/0
C 192.168.2.0/24 is directly connected, FastEthernet0/1
C 192.168.10.0/24 is directly connected, FastEthernet0/0
Router1#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
192.168.10.1 1 FULL/BDR 00:00:33 192.168.10.1 FastEthernet0/0
Router1がDRになり、ルーティングテーブルにOSPFの経路が載った。
2. マルチエリアOSPF
ルータの数を増やしてマルチエリアOSPFを実装する。
以降、IPアドレスの設定は省略する。
Router0(config)#router ospf 1
Router0(config-router)#network 192.168.1.0 0.0.0.255 area 0
Router0(config-router)#network 192.168.10.0 0.0.0.255 area 0
//確認
Router0#show ip route
~略~
Gateway of last resort is not set
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/24 is directly connected, FastEthernet0/1
L 192.168.1.1/32 is directly connected, FastEthernet0/1
O IA 192.168.2.0/24 [110/3] via 192.168.10.254, 00:10:15, FastEthernet0/0
192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/24 is directly connected, FastEthernet0/0
L 192.168.10.1/32 is directly connected, FastEthernet0/0
O IA 192.168.20.0/24 [110/2] via 192.168.10.254, 00:11:08, FastEthernet0/0
Router1(config)#router ospf 1
Router1(config-router)#network 192.168.10.0 0.0.0.255 area 0
Router1(config-router)#network 192.168.20.0 0.0.0.255 area 1
//確認
Router1#show ip ospf database
OSPF Router with ID (192.168.20.1) (Process ID 1)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
192.168.20.1 192.168.20.1 208 0x80000003 0x004727 1
192.168.10.1 192.168.10.1 208 0x80000003 0x0015f0 2
Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
192.168.10.1 192.168.10.1 208 0x80000001 0x007f93
Summary Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
192.168.20.0 192.168.20.1 203 0x80000001 0x0066fb
192.168.2.0 192.168.20.1 145 0x80000002 0x00353d
Router Link States (Area 1)
Link ID ADV Router Age Seq# Checksum Link count
192.168.20.1 192.168.20.1 150 0x80000002 0x002e2d 1
192.168.20.254 192.168.20.254 150 0x80000003 0x006084 2
Net Link States (Area 1)
Link ID ADV Router Age Seq# Checksum
192.168.20.254 192.168.20.254 150 0x80000001 0x00b33d
Summary Net Link States (Area 1)
Link ID ADV Router Age Seq# Checksum
192.168.10.0 192.168.20.1 203 0x80000001 0x00d497
192.168.1.0 192.168.20.1 203 0x80000002 0x004033
Router2(config)#router ospf 1
Router2(config-router)#network 192.168.20.0 0.0.0.255 are
Router2(config-router)#network 192.168.20.0 0.0.0.255 area 1
Router2(config-router)#network 192.168.2.0 0.0.0.255 area 1
//確認
Router2#show ip route
~略~
Gateway of last resort is not set
O IA 192.168.1.0/24 [110/3] via 192.168.20.1, 00:10:33, FastEthernet0/0
192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.2.0/24 is directly connected, FastEthernet0/1
L 192.168.2.1/32 is directly connected, FastEthernet0/1
O IA 192.168.10.0/24 [110/2] via 192.168.20.1, 00:10:33, FastEthernet0/0
192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.20.0/24 is directly connected, FastEthernet0/0
L 192.168.20.254/32 is directly connected, FastEthernet0/0
Router1のLSDBよりエリアが2つ存在することがわかる。
ルーティングテーブルにも反映されている。
3. 実際に障害を起こしてみる
2拠点間のルーティングという想定でOSPFを設定して実際にネットワーク障害を起こしてみる。
(この時点でPacket Tracerに図形やメモを記入する機能があることに気づいた。)
通常時はRouter1経由の経路にするため、Router2経由のインターフェースにコスト10を設定する。
Router0(config)#router ospf 1
Router0(config-router)#network 192.168.1.1 0.0.0.0 area 0
Router0(config-router)#network 192.168.10.1 0.0.0.0 area 0
Router0(config-router)#network 192.168.13.254 0.0.0.0 area 0
Router0(config-router)#exit
Router0(config)#interface fa0/1
Router0(config-if)#ip ospf cost 10
//結果
Router0#show ip route
~略~
Gateway of last resort is not set
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/24 is directly connected, FastEthernet1/1
L 192.168.1.1/32 is directly connected, FastEthernet1/1
O 192.168.2.0/24 [110/3] via 192.168.10.254, 00:00:53, FastEthernet0/0 //Router1経由ルーティング
192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/24 is directly connected, FastEthernet0/0
L 192.168.10.1/32 is directly connected, FastEthernet0/0
O 192.168.11.0/24 [110/2] via 192.168.10.254, 00:03:59, FastEthernet0/0
O 192.168.12.0/24 [110/11] via 192.168.13.1, 00:01:25, FastEthernet0/1
192.168.13.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.13.0/24 is directly connected, FastEthernet0/1
L 192.168.13.254/32 is directly connected, FastEthernet0/1
Router1(config)#router ospf 1
Router1(config-router)#network 192.168.10.0 0.0.1.255 area 0
Router2(config)#router ospf 1
Router2(config-router)#network 192.168.12.0 0.0.1.255 area 0
Router3(config)#router ospf 1
Router3(config-router)#network 192.168.2.1 0.0.0.0 area 0
Router3(config-router)#network 192.168.11.254 0.0.0.0 area 0
Router3(config-router)#network 192.168.12.1 0.0.0.0 area 0
Router3(config-router)#exit
Router3(config)#interface fa 0/0
Router3(config-if)#ip os
Router3(config-if)#ip ospf cost 10
Router3(config-if)#
//結果
Router3#show ip route
~略~
Gateway of last resort is not set
O 192.168.1.0/24 [110/3] via 192.168.11.1, 00:03:03, FastEthernet0/1 //Router1経由ルーティング
192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.2.0/24 is directly connected, FastEthernet1/1
L 192.168.2.1/32 is directly connected, FastEthernet1/1
O 192.168.10.0/24 [110/2] via 192.168.11.1, 00:03:32, FastEthernet0/1
192.168.11.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.11.0/24 is directly connected, FastEthernet0/1
L 192.168.11.254/32 is directly connected, FastEthernet0/1
192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.12.0/24 is directly connected, FastEthernet0/0
L 192.168.12.1/32 is directly connected, FastEthernet0/0
O 192.168.13.0/24 [110/11] via 192.168.12.254, 00:02:18, FastEthernet0/0
ルーティングテーブルにRouter1経由の経路が載っていることがわかる。
実際にパケットがRouter1経由になっているか確認する
PCからtracert
コマンドを打って確認してもいいが、ここはシミュレーションモードでパケットの動きを見てみる。
画面右下のSimutarion
ボタンを押すとデフォルトのリアルタイムモードから、シミュレーションモードに切り替わり、シミュレーションパネルが開く。
PC0からPC1宛にpingを打つとプロンプトが止まる。
メイン画面の方ではパケットを表すメールのアイコンが表示され、シミュレーションパネルにはICMP
表示のパケットがリストに入る。(余計なOSPFやSTPのデータを表示させないために、フィルターをかけている)
パケットがRouter1経由でルーティングされていることがわかった。
Router1のFa10/1
(192.168.10.0/24側)を無効にして同じようにpingを打ってみる。
最初のパケットは破棄されたが、2つ目からRouter2経由の経路が使用された。
気になったこと,覚えておきたいこと
- OSPFを有効にしたインターフェイスのネットワークをルーティングテーブルに載せるので、ルーティングしてほしいネットワークで有効にしないといけない。
Ex. 実践-1において192.168.10.0/24
だけ有効にしているとPCがあるネットワークがルーティングテーブルに載らない。 - 実践-1において、OSPFの設定直後はRouter0がDRに選出されていた。ルータを再起動すると正しくRouter1がDRに選出された。-> 先にRouter0のOSPFを設定したのが原因?
参考サイト