Help us understand the problem. What is going on with this article?

yarn install時に、error : The engine "node" is incompatible with this module.

More than 1 year has passed since last update.

yarn installしたときにeslintがインストールできなくて詰まったので、解決策を書きます。

エラー

error eslint@5.8.0: The engine "node" is incompatible with this module. Expected version "^6.14.0 || ^8.10.0 || >=9.10.0".
error Found incompatible module.
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.

発生環境

  • node: 8.9.4
  • yarn: 1.9.4

解決策

yarn install --ignore-engines

これでだめならnodeのバージョンを下げて解決する場合もある。

参考

NAKKA-K
趣味はリファクタリング。 Laravel, React, Scrum, 筋トレを良くするWebエンジニア。
https://nakka-k.hatenablog.com/
Why not register and get more from Qiita?
  1. We will deliver articles that match you
    By following users and tags, you can catch up information on technical fields that you are interested in as a whole
  2. you can read useful information later efficiently
    By "stocking" the articles you like, you can search right away
Comments
No comments
Sign up for free and join this conversation.
If you already have a Qiita account
Why do not you register as a user and use Qiita more conveniently?
You need to log in to use this function. Qiita can be used more conveniently after logging in.
You seem to be reading articles frequently this month. Qiita can be used more conveniently after logging in.
  1. We will deliver articles that match you
    By following users and tags, you can catch up information on technical fields that you are interested in as a whole
  2. you can read useful information later efficiently
    By "stocking" the articles you like, you can search right away
ユーザーは見つかりませんでした