Edited at

Pythonのライブラリをインストールできないときに確認したいこと

More than 1 year has passed since last update.

よくPythonのライブラリをインストールすると(特にRaspberry Piを使っていた時に)、エラーの中にこんな記述がありませんか?

Command "python setup.py egg_info" failed with error code 1

このようなエラーが出るときはセットアップツールをアップデートをすると、解決できることがあります。Raspberry Piを使っているなら以下のコマンドを入力します。

$ sudo pip install --upgrade setuptools