search
LoginSignup
0

More than 1 year has passed since last update.

posted at

You must use Bundler 2 or greater with this lockfile.の対処法

Dockerを動かそうdocker-compose up --buildをしたところ、次のエラーが表示されDockerを立ち上げることができませんでした。

You must use Bundler 2 or greater with this lockfile

原因

最近(2019年)に表示されることが多くなったエラー。
・根本原因は不明だが、Bundlerのバージョン2.0.1が悪さをしているらしい。

対処法

Gemfile.lockを右クリックでゴミ箱に移す(削除する)

gem install bundler -v 1.17.3を実行し、古いgemを取得。

docker-compose up --buildをしたところ、

Your Ruby version is 2.5.1, but your Gemfile specified 2.6.3

というエラー文が表示されたのでgemfile内の上記部分を


ruby '~> 2.5.1

に書き換え、再びdocker-compose up --build

dockerが正常に動きました。

参考URL
https://qiita.com/kHigasa/items/2e9764e7e80d1bdd8186

Register as a new user and use Qiita more conveniently

  1. You get articles that match your needs
  2. You can efficiently read back useful information
What you can do with signing up
0