Help us understand the problem. What is going on with this article?

[Swift] forとifを入れ子にするよりfor whereを使おう

随分前からある構文ですが、私は最近気づいたので改めて書きます。
Swiftを書いていると時折こういうコードを書く必要が出てきます。

var count = 0
for i in 0..<n{
    if condition(i){
        count += 1
    }
}

forの直下にifがあり、かつelseがない場合です。

でもwhereを使えばこう書けます。

var count = 0
for i in 0..<n where condition(i){
    count += 1
}

意味は簡単で、where節が条件を指定しています。こう書くことでネストが1つ減るだけでなく、考えている条件もわかりやすくなります。
最適化のおかげでパフォーマンス上の影響は全くないので、積極的に使っていくべきだと思います。

En3_HCl
swiftユーザ。iOSのkeyboard extensionを作っています。
https://github.com/En3-HCl
Why not register and get more from Qiita?
  1. We will deliver articles that match you
    By following users and tags, you can catch up information on technical fields that you are interested in as a whole
  2. you can read useful information later efficiently
    By "stocking" the articles you like, you can search right away