1. yukkie

    Posted

    yukkie
Changes in title
+Rails tutorial 第3章
Changes in tags
Changes in body
Source | HTML | Preview
@@ -0,0 +1,36 @@
+#### rails generateしたときに、```undefined method Application' for Rails:Module (NoMethodError)```とエラーが出る件。
+
+Windows版だとrails installerを使ってインストールするので、rails newする時に毎回バージョン指定が必要。
+参考
+-http://qiita.com/gakuo/items/4a38765f62385af442e9
+
+#### サーバーにアクセスすると"ExecJS::ProgramError TypeError"と表示される。
+これもWindows特有のエラーらしい。
+coffee-script-sourceのモジュールバージョンを落とす。
+参考
+-http://www.oiax.jp/books/rails3book/coffee-script-type-error.html
+
+### RailsをIDEで開発
+Apatana Studioが推奨らしい。
+
+Aptana Studio本体のインストールではRubyの開発環境が入ってないので、以下を参照して追加インストール。
+- http://www.rubylife.jp/aptana/ruby/index4.html
+CTRL+SHIFT+Tとか使えなくて余りIDEにする利便性を感じない・・・・
+
+### IDE上からRun Serverしようとするとコケる。
+IDEは./script/railsというコマンドがあることを想定しているが、実際は./bin/railsにコマンドがあるため。
+IDEの設定が変更できないため、scriptフォルダを作成して、binフォルダの内容を丸コピするしかない。
+-http://stackoverflow.com/questions/19704541/rails-4-0-project-not-starting-through-aptana-studio-3
+
+### Aptana Studioでデバッグ
+-http://doruby.kbmj.com/nakahira_on_rails/20080313/aptana_rails_
+を参考にするも、```gem install ruby-debug-base```でコケる。
+調べると、依存モジュールのうち、linecacheというモジュールがRuby1.9以上をサポートしていないらしい。。
+
+-http://stackoverflow.com/questions/24347956/cant-handle-1-9-x-error-when-trying-to-install-linecache-with-ruby-2-1-1
+
+Rubyの複数バージョンの共存はWindowsでは面倒くさそうなのでとりあえずスキップする。
+
+### 余談
+全般的にRailsやRuby開発者はIDEをほとんど使わない印象。
+メンテナンスされてない上に機能がしょぼい。