Edited at

Eclipse4.9はJava11対応してないからな?

デフォルトでは。

Java11が使いたいならMarketplaceから拡張をインストールしよう。

設定方法などはこちらから:

なお、12/19にJava11完全対応Eclipse4.10がリリースされました!

12/20リリースの Spring Tools 4 for Eclipse 4.1.0もこれがベースになっているようです。