Edited at

Ubuntu12.04でimage-magickとrmagickを入れる

More than 5 years have passed since last update.

rmagick gemをインストールする際、Magick-configがないとかMagicWand.hがないとかで怒られることが多い

Can't install RMagick 2.13.1. Can't find Magick-config

Can't install RMagick 2.13.1. Can't find MagickWand.h

などのエラーがおきる

apt使うのを諦めてソースから入れている事例も多いが以下のようにパッケージを入れれば問題なかった

sudo aptitude install imagemagick libimagemagick libmagickcore libmagickcore-dev libmagickwand-dev

sudo gem install rmagick