yumのセキュリティアップデートコマンドはCentOSでは効果がない

  • 77
    Like
  • 0
    Comment
More than 1 year has passed since last update.

yum経由でセキュリティアップデートをしようとyum-plugin-securityをインストールし、
yum --security upgrade-minimalを実行しました。
しかし、セキュリティパッチが存在するにも関わらず、
何度実行してもNo Packages marked for minimal Updateというメッセージしか出ません。

これはCentOSのリポジトリにセキュリティ情報が存在しないためです。
RHELやAmazon Linuxでは問題なく利用できるようです。

どうしてもCentOSでセキュリティアップデートしたい場合は、
https://github.com/vmfarms/generate_updateinfo
を利用しましょう。
CentOS用にセキュリティ情報を更新しているサイトからデータを取ってくることで、
セキュリティアップデートが可能になります。

関連記事