search
LoginSignup
2

More than 3 years have passed since last update.

posted at

Cocoapodsを利用してライブラリのアップデートが出来ないとき

Cocoapodsを利用してライブラリのアップデートが出来ないとき

環境

  • Xcode 9.4.1
  • Swift 4.1
  • CocoaPods 1.5.3
  • Buldler 1.16.2

対応方法

Realmのバージョンを上げるためPodfileを変更し

pod install

を実行したところ

[!] Unable to satisfy the following requirements:

- `RealmSwift (~> 2.8.2)` required by `Podfile`
- `RealmSwift (~> 2.8.2)` required by `Podfile`

None of your spec sources contain a spec satisfying the dependency: `RealmSwift (~> 2.8.2)`.

You have either:
 * out-of-date source repos which you can update with `pod repo update`.
 * mistyped the name or version.
 * not added the source repo that hosts the Podspec to your Podfile.

Note: as of CocoaPods 1.0, `pod repo update` does not happen on `pod install` by default.

というエラーが...
CocoaPodsのSpecsを最新にするためのgit pullで止まっているらしい。
以下参照
http://d.akiroom.com/2015-08/pod-install-forever/

cd ~/.cocoapods/repos
git clone https://github.com/CocoaPods/Specs.git master

上記でCocoapodsのリポジトリをcloneした後に

pod setup
pod install

これで解決

私の場合はRelamでしたが、他のライブラリでもどうようなのではないかと思います。
誰かの助けになれば幸いです。

Register as a new user and use Qiita more conveniently

  1. You get articles that match your needs
  2. You can efficiently read back useful information
What you can do with signing up
2