1. wakaba@github

    Posted

    wakaba@github
Changes in title
+.travis.yml には language が必要
Changes in tags
Changes in body
Source | HTML | Preview
@@ -0,0 +1,18 @@
+いままでは .travis.yml に
+
+```yaml
+perl:
+ - "5.18"
+ - "5.8"
+```
+
+のように書いておけば Perl 5.8 と 5.18 で実行してくれていましたが、いつからか
+
+```yaml
+language: perl
+perl:
+ - "5.18"
+ - "5.8"
+```
+
+のように `language` を指定しないと `perl` が無視されるようになっていました。 (ドキュメントにはちゃんと `language` を指定するようにと書いてありました。昔からそう書いてあったのかは知りません。)