Python
GoogleAppEngine

Google App Engine 上で tweepy を使うときに必要な設定

More than 5 years have passed since last update.

app.yaml に次の項目を追加する


app.yaml

libraries:

- name: ssl
version: "latest"


そうしないと

ImportError が発生します

ImportError: No module named _ssl


なんで


The Python 2.7 runtime includes some third-party modules. Some of these are available by default; others are only available if configured. You can specify which version you want to use.


Python Application Configuration with app.yaml より引用)

どうやら ssl ライブラリを使用する際に app.yaml にその旨を記述しなければならないようです