1. unnonouno

    No comment

    unnonouno
Changes in body
Source | HTML | Preview
@@ -42,10 +42,20 @@
pip install -upgrade pip
```
してください。これは、h5pyのバージョンが上がると解消されるかもしれません。
+## Cythonを先にインストールする
+
+Cythonを使ったライブラリのインストールは、全体的に失敗しやすくなっているようです。Cythonは利用時はもとより、インストール **時** に必要になります。.pyxファイルを.cppに変換する必要があるからです。
+h5pyのsetup.pyに問題がある(?)ようで、masterブランチでは直っていますが、2.5.0では`setup_require`にCythonがありません。そのせいで、ビルド時にCythonを見つけられずに失敗することが有ります(何らかの要因でCythonの方が先に入って、成功することも有ります)。
+先に、
+```
+pip install cython
+```
+しましょう。
+
## Chainerがたくさんいる
Chainerが沢山インストールされている事があります。アンインストール時は、`pip uninstall chainer`を、警告が出なくなるまで繰り返してください。
## 何かゴミが残っている