Posted at

cakephp2のインストールはcomposer.jsonにphpのバージョンを明記

以前こちらの記事に書いたcakephp2の始め方だが、

https://qiita.com/uedatakeshi/items/08d5c577e07489c4d9f9

いざやってみると最新のcakephp2だと依存関係でphp5.3に対応していないようなライブラリが入ってしまい、エラーを起こす、ことがあるようだ。

私が遭遇したのはphp5.4のサーバー。markbakerというやつがひっかかって動かない。

https://github.com/MarkBaker/PHPComplex

どうもphp5.6以上対応のようである。

ということでcomposer.jsonに以下を追加。


composer.json

    "require": {

"php": "^5.4.0",

すると今度は

  Problem 1

- This package requires php ^5.4.0 but your PHP version (7.0.22) does not satisfy that requirement.

とcomposerに怒られる。走らせてるローカルのphpが7だとだめみたい。

しょうがないので昔入れたphp54とcomposer.pharを使ってinstall

curl -sS https://getcomposer.org/installer | php

sudo php54 composer.phar install

markbakerは消えました。。。