LoginSignup
2
2

More than 5 years have passed since last update.

GNS3を使用しての Cisco BGP 構築練習

Last updated at Posted at 2019-01-14

GNS3を使用しての Cisco BGP 構築メモ

  • 本ページは、BGPの自己学習の内容をまとめたものです。そのため「設計的に??」な部分が多々あります。
  • ベストプラクティスではありませんので実際の構築の参考にはしないでください。
  • 目的として以下のメモや忘備録として作成しました。
    • BGPの簡易構成や設定
    • BGP系showコマンド出力(※特にコレ)
    • GNS3の使い方

機器構成

仮想PC x 3台
・VPCS(Virtual PC Simulator)
※GNS3付属の仮想PC

仮想ルータ x 6台
・Cisco C3660-JK9O3S-M/Software Version 12.4(25d)


仮想ルータ初期コンフィグ(GNS3での出力)
初期コンフィグ出力
R1#show run
Building configuration...

Current configuration : 1363 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 no ip address
!
no ip http server
no ip http secure-server
ip forward-protocol nd
!
!
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R1#

~~~ここまで~~~


構成図(GNS3で作成)

GNS3で作成した構成図
※精度が良くないですがGNS3の勉強も兼ねているのでこれで良しとします。。。

image.png

構成の説明

BGP学習がメインのため、セキュリティとかはかなり薄いです。

ISP側は冗長のため2つと接続。

フィルター(ACL, Prefix-List)はオーソドックスなものをAS1000-RTで設定(静的のみ)。

構成図右側を非優先にするため、AS-patsh-prependやmedを設定。

経路配信
・外部接続ルータ→ISPは「100.0.0.0/24」のみを配信。
・外部接続ルータ→内部は「0.0.0.0/0」のみを配信。
・ISP→外部接続ルータはFull Route受け取るが、Prefix-List分をdeny。
※show bgp all neighbors **** received-routes でdeny前の経路情報を表示

疑似ISP(Internet Services Provider)側として3台のルータを設置
・AS10-ISP-RT ・・・ ISP側の中心、ネットワーク等の配信を実施
・AS20-ISP-RT ・・・ 中継ルータ
・AS30-ISP-RT ・・・ 中継ルータ(非優先)

疑似ISPに2台のPCを設置
・ISP-PC ・・・ あちこちとPing可能
・PrivateIP ・・・ プライベートIPを割り当てているためAS1000-RT-[12]でフィルターされる

内部ルータとして3台のルータを設置
・AS1000-RT-1 ・・・ 外部接続ルータのためグローバルAS番号
・AS1000-RT-2 ・・・ 外部接続ルータのためグローバルAS番号(非優先)

内部に1台のPCを設置
・PC ・・・ 内部ユーザ、ISP側と通信可

設定およびshowコマンド出力

showコマンドは以下を出力しています。

show running-config
show ip route
show bgp
・・・BGPで受け取った経路情報を表示
show bgp all summary
・・・BGP peerの一覧やpeerの状態を表示
show bgp all neighbors peer-IPaddress routes
・・・指定peerから受け取った経路情報を表示(フィルター後)
show bgp all neighbors peer-IPaddress received-routes
・・・指定peerから受け取った経路情報を表示(フィルター前)
・・・ただし対向装置で「neighbor soft-reconfiguration inbound」が有効なこと
show bgp all neighbors peer-IPaddress advertised-routes
・・・指定peerへ広報している経路情報を表示

※show ip bgp でなく、 show bgp all なのは、IPv6も表示できるからです。IPv6使ってないけど。



・AS10-ISP-RT
AS10-ISP-RT

AS10-ISP-RT#show running-config
Building configuration...

Current configuration : 3601 bytes
!
version 12.4
service timestamps debug datetime localtime
service timestamps log datetime localtime
no service password-encryption
!
hostname AS10-ISP-RT
!
boot-start-marker
boot-end-marker
!
enable secret admin
!
no aaa new-model
memory-size iomem 5
clock timezone JST 9
no ip source-route
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username admin password admin
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 description to_AS20-ISP-RT
 ip address 200.20.0.254 255.255.255.0
 no ip redirects
 no ip proxy-arp
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description to_AS30-ISP-RT
 ip address 200.30.0.254 255.255.255.0
 no ip redirects
 no ip proxy-arp
 duplex auto
 speed auto
!
interface FastEthernet1/0
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
 description to_ISP-PC
 no switchport
 ip address 200.10.0.254 255.255.255.0
 no ip redirects
 no ip proxy-arp
!
interface FastEthernet1/11
 description to_PrivateIP
 no switchport
 ip address 192.168.10.254 255.255.255.0
 no ip redirects
 no ip proxy-arp
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 no ip address
!
router bgp 10
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 bgp maxas-limit 100
 timers bgp 30 90
 neighbor 200.20.0.1 remote-as 20
 neighbor 200.20.0.1 description AS20-ISP-RT
 neighbor 200.30.0.1 remote-as 30
 neighbor 200.30.0.1 description AS30-ISP-RT
 !
 address-family ipv4
  redistribute connected metric 100 route-map RM_connect-to-BGP
  neighbor 200.20.0.1 activate
  neighbor 200.20.0.1 soft-reconfiguration inbound
  neighbor 200.30.0.1 activate
  neighbor 200.30.0.1 soft-reconfiguration inbound
  neighbor 200.30.0.1 route-map RM_AS-prepend out
  no auto-summary
  no synchronization
 exit-address-family
!
no ip http server
no ip http secure-server
ip forward-protocol nd
!
!
!
!
ip prefix-list PL_connect-to-BGP seq 10 permit 1.1.1.1/32
ip prefix-list PL_connect-to-BGP seq 20 permit 200.10.0.0/24
ip prefix-list PL_connect-to-BGP seq 30 permit 200.20.0.0/24
ip prefix-list PL_connect-to-BGP seq 40 permit 200.30.0.0/24
ip prefix-list PL_connect-to-BGP seq 50 permit 192.168.10.0/24
ip prefix-list PL_connect-to-BGP seq 999 deny 0.0.0.0/0 le 32
!
no cdp log mismatch duplex
!
route-map RM_AS-prepend permit 10
 set as-path prepend 10
!
route-map RM_connect-to-BGP permit 10
 match ip address prefix-list PL_connect-to-BGP
 set origin igp
!
route-map RM_connect-to-BGP deny 20
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 login local
line aux 0
 exec-timeout 0 0
line vty 0 4
 exec-timeout 0 0
 logging synchronous
 login local
 transport input ssh telnet
!
!
end







AS10-ISP-RT#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     2.0.0.0/32 is subnetted, 1 subnets
B       2.2.2.2 [20/0] via 200.20.0.1, 00:59:46
     100.0.0.0/24 is subnetted, 1 subnets
B       100.0.0.0 [20/0] via 200.20.0.1, 00:59:16
     3.0.0.0/32 is subnetted, 1 subnets
B       3.3.3.3 [20/0] via 200.30.0.1, 00:59:44
C    200.10.0.0/24 is directly connected, FastEthernet1/10
C    200.20.0.0/24 is directly connected, FastEthernet0/0
C    200.30.0.0/24 is directly connected, FastEthernet0/1
C    192.168.10.0/24 is directly connected, FastEthernet1/11






AS10-ISP-RT#show bgp
BGP table version is 10, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       0.0.0.0                100         32768 i
*> 2.2.2.2/32       200.20.0.1               0             0 20 i
*> 3.3.3.3/32       200.30.0.1               0             0 30 30 i
*> 100.0.0.0/24     200.20.0.1                             0 20 1000 i
*                   200.30.0.1                             0 30 30 1000 i
*> 192.168.10.0     0.0.0.0                100         32768 i
*> 200.10.0.0       0.0.0.0                100         32768 i
*> 200.20.0.0       0.0.0.0                100         32768 i
*> 200.30.0.0       0.0.0.0                100         32768 i






AS10-ISP-RT#show bgp all summary
For address family: IPv4 Unicast
BGP router identifier 1.1.1.1, local AS number 10
BGP table version is 10, main routing table version 10
8 network entries using 936 bytes of memory
9 path entries using 468 bytes of memory
6/4 BGP path/bestpath attribute entries using 744 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2244 total bytes of memory
BGP activity 8/0 prefixes, 9/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
200.20.0.1      4    20     129     129       10    0    0 01:00:35        2
200.30.0.1      4    30     126     128       10    0    0 01:00:39        2






AS10-ISP-RT#show bgp all neighbors 200.20.0.1 routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 2.2.2.2/32       200.20.0.1               0             0 20 i
*> 100.0.0.0/24     200.20.0.1                             0 20 1000 i

Total number of prefixes 2






AS10-ISP-RT#show bgp all neighbors 200.20.0.1 received-routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 2.2.2.2/32       200.20.0.1               0             0 20 i
*> 100.0.0.0/24     200.20.0.1                             0 20 1000 i

Total number of prefixes 2






AS10-ISP-RT#show bgp all neighbors 200.20.0.1 advertised-routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       0.0.0.0                100         32768 i
*> 3.3.3.3/32       200.30.0.1               0             0 30 30 i
*> 192.168.10.0     0.0.0.0                100         32768 i
*> 200.10.0.0       0.0.0.0                100         32768 i
*> 200.20.0.0       0.0.0.0                100         32768 i
*> 200.30.0.0       0.0.0.0                100         32768 i

Total number of prefixes 6





AS10-ISP-RT#show bgp all neighbors 200.30.0.1 routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 3.3.3.3/32       200.30.0.1               0             0 30 30 i
*  100.0.0.0/24     200.30.0.1                             0 30 30 1000 i

Total number of prefixes 2






AS10-ISP-RT#show bgp all neighbors 200.30.0.1 received-routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 3.3.3.3/32       200.30.0.1               0             0 30 30 i
*  100.0.0.0/24     200.30.0.1                             0 30 30 1000 i

Total number of prefixes 2






AS10-ISP-RT#show bgp all neighbors 200.30.0.1 advertised-routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       0.0.0.0                100         32768 i
*> 2.2.2.2/32       200.20.0.1               0             0 20 i
*> 100.0.0.0/24     200.20.0.1                             0 20 1000 i
*> 192.168.10.0     0.0.0.0                100         32768 i
*> 200.10.0.0       0.0.0.0                100         32768 i
*> 200.20.0.0       0.0.0.0                100         32768 i
*> 200.30.0.0       0.0.0.0                100         32768 i

Total number of prefixes 7




・AS20-ISP-RT
AS20-ISP-RT

AS20-ISP-RT#show running-config
Building configuration...

Current configuration : 2759 bytes
!
version 12.4
service timestamps debug datetime localtime
service timestamps log datetime localtime
no service password-encryption
!
hostname AS20-ISP-RT
!
boot-start-marker
boot-end-marker
!
enable secret admin
!
no aaa new-model
memory-size iomem 5
clock timezone JST 9
no ip source-route
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username admin password admin
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 description to_AS10-ISP-RT
 ip address 200.20.0.1 255.255.255.0
 no ip redirects
 no ip proxy-arp
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description to_AS1000-RT-1
 ip address 200.20.1.254 255.255.255.0
 no ip redirects
 no ip proxy-arp
 duplex auto
 speed auto
!
interface FastEthernet1/0
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 no ip address
!
router bgp 20
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 bgp maxas-limit 100
 timers bgp 30 90
 neighbor 200.20.0.254 remote-as 10
 neighbor 200.20.0.254 description AS10-ISP-RT
 neighbor 200.20.1.1 remote-as 1000
 neighbor 200.20.1.1 description AS1000-RT-1
 !
 address-family ipv4
  neighbor 200.20.0.254 activate
  neighbor 200.20.0.254 soft-reconfiguration inbound
  neighbor 200.20.1.1 activate
  neighbor 200.20.1.1 soft-reconfiguration inbound
  no auto-summary
  no synchronization
  network 2.2.2.2 mask 255.255.255.255
 exit-address-family
!
no ip http server
no ip http secure-server
ip forward-protocol nd
!
!
!
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 login local
line aux 0
 exec-timeout 0 0
line vty 0 4
 exec-timeout 0 0
 logging synchronous
 login local
 transport input ssh telnet
!
!
end






AS20-ISP-RT#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
B       1.1.1.1 [20/100] via 200.20.0.254, 01:10:31
     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     100.0.0.0/24 is subnetted, 1 subnets
B       100.0.0.0 [20/0] via 200.20.1.1, 01:10:30
     3.0.0.0/32 is subnetted, 1 subnets
B       3.3.3.3 [20/0] via 200.20.0.254, 01:10:01
B    200.10.0.0/24 [20/100] via 200.20.0.254, 01:10:31
C    200.20.0.0/24 is directly connected, FastEthernet0/0
B    200.30.0.0/24 [20/100] via 200.20.0.254, 01:10:32
C    200.20.1.0/24 is directly connected, FastEthernet0/1
B    192.168.10.0/24 [20/100] via 200.20.0.254, 00:50:20





AS20-ISP-RT#show bgp
BGP table version is 10, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       200.20.0.254           100             0 10 i
*> 2.2.2.2/32       0.0.0.0                  0         32768 i
*> 3.3.3.3/32       200.20.0.254                           0 10 30 30 i
*> 100.0.0.0/24     200.20.1.1               0             0 1000 i
*> 192.168.10.0     200.20.0.254           100             0 10 i
*> 200.10.0.0       200.20.0.254           100             0 10 i
r> 200.20.0.0       200.20.0.254           100             0 10 i
*> 200.30.0.0       200.20.0.254           100             0 10 i





AS20-ISP-RT#show bgp all summary
For address family: IPv4 Unicast
BGP router identifier 2.2.2.2, local AS number 20
BGP table version is 10, main routing table version 10
8 network entries using 936 bytes of memory
8 path entries using 416 bytes of memory
5/4 BGP path/bestpath attribute entries using 620 bytes of memory
3 BGP AS-PATH entries using 72 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2044 total bytes of memory
BGP activity 8/0 prefixes, 9/1 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
200.20.0.254    4    10     150     150       10    0    0 01:11:04        6
200.20.1.1      4  1000     146     150       10    0    0 01:11:07        1





AS20-ISP-RT#show bgp all neighbors 200.20.0.254 routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       200.20.0.254           100             0 10 i
*> 3.3.3.3/32       200.20.0.254                           0 10 30 30 i
*> 192.168.10.0     200.20.0.254           100             0 10 i
*> 200.10.0.0       200.20.0.254           100             0 10 i
r> 200.20.0.0       200.20.0.254           100             0 10 i
*> 200.30.0.0       200.20.0.254           100             0 10 i

Total number of prefixes 6





AS20-ISP-RT#show bgp all neighbors 200.20.0.254 received-routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       200.20.0.254           100             0 10 i
*> 3.3.3.3/32       200.20.0.254                           0 10 30 30 i
*> 192.168.10.0     200.20.0.254           100             0 10 i
*> 200.10.0.0       200.20.0.254           100             0 10 i
r> 200.20.0.0       200.20.0.254           100             0 10 i
*> 200.30.0.0       200.20.0.254           100             0 10 i

Total number of prefixes 6





AS20-ISP-RT#show bgp all neighbors 200.20.0.254 advertised-routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       200.20.0.254           100             0 10 i
*> 2.2.2.2/32       0.0.0.0                  0         32768 i
*> 3.3.3.3/32       200.20.0.254                           0 10 30 30 i
*> 100.0.0.0/24     200.20.1.1               0             0 1000 i
*> 192.168.10.0     200.20.0.254           100             0 10 i
*> 200.10.0.0       200.20.0.254           100             0 10 i
r> 200.20.0.0       200.20.0.254           100             0 10 i
*> 200.30.0.0       200.20.0.254           100             0 10 i

Total number of prefixes 8





AS20-ISP-RT#show bgp all neighbors 200.20.1.1 routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 100.0.0.0/24     200.20.1.1               0             0 1000 i

Total number of prefixes 1






AS20-ISP-RT#show bgp all neighbors 200.20.1.1 received-routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 100.0.0.0/24     200.20.1.1               0             0 1000 i

Total number of prefixes 1






AS20-ISP-RT#show bgp all neighbors 200.20.1.1 advertised-routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       200.20.0.254           100             0 10 i
*> 2.2.2.2/32       0.0.0.0                  0         32768 i
*> 3.3.3.3/32       200.20.0.254                           0 10 30 30 i
*> 100.0.0.0/24     200.20.1.1               0             0 1000 i
*> 192.168.10.0     200.20.0.254           100             0 10 i
*> 200.10.0.0       200.20.0.254           100             0 10 i
r> 200.20.0.0       200.20.0.254           100             0 10 i
*> 200.30.0.0       200.20.0.254           100             0 10 i

Total number of prefixes 8





・AS30-ISP-RT
AS30-ISP-RT

AS30-ISP-RT#show running-config
Building configuration...

Current configuration : 2869 bytes
!
version 12.4
service timestamps debug datetime localtime
service timestamps log datetime localtime
no service password-encryption
!
hostname AS30-ISP-RT
!
boot-start-marker
boot-end-marker
!
enable secret admin
!
no aaa new-model
memory-size iomem 5
clock timezone JST 9
no ip source-route
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username admin password admin
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 description to_AS10-ISP-RT
 ip address 200.30.0.1 255.255.255.0
 no ip redirects
 no ip proxy-arp
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description to_AS1000-RT-2
 ip address 200.30.1.254 255.255.255.0
 no ip redirects
 no ip proxy-arp
 duplex auto
 speed auto
!
interface FastEthernet1/0
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 no ip address
!
router bgp 30
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 bgp maxas-limit 100
 timers bgp 30 90
 neighbor 200.30.0.254 remote-as 10
 neighbor 200.30.0.254 description AS10-ISP-RT
 neighbor 200.30.1.1 remote-as 1000
 neighbor 200.30.1.1 description AS1000-RT-2
 !
 address-family ipv4
  neighbor 200.30.0.254 activate
  neighbor 200.30.0.254 soft-reconfiguration inbound
  neighbor 200.30.0.254 route-map RM_AS-prepend out
  neighbor 200.30.1.1 activate
  neighbor 200.30.1.1 soft-reconfiguration inbound
  no auto-summary
  no synchronization
  network 3.3.3.3 mask 255.255.255.255
 exit-address-family
!
no ip http server
no ip http secure-server
ip forward-protocol nd
!
!
!
!
no cdp log mismatch duplex
!
route-map RM_AS-prepend permit 10
 set as-path prepend 30
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 login local
line aux 0
 exec-timeout 0 0
line vty 0 4
 exec-timeout 0 0
 logging synchronous
 login local
 transport input ssh telnet
!
!
end






AS30-ISP-RT#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
B       1.1.1.1 [20/100] via 200.30.0.254, 01:58:31
     2.0.0.0/32 is subnetted, 1 subnets
B       2.2.2.2 [20/0] via 200.30.0.254, 01:58:31
     100.0.0.0/24 is subnetted, 1 subnets
B       100.0.0.0 [20/0] via 200.30.1.1, 01:58:31
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
B    200.10.0.0/24 [20/100] via 200.30.0.254, 01:58:32
B    200.20.0.0/24 [20/100] via 200.30.0.254, 01:58:32
C    200.30.0.0/24 is directly connected, FastEthernet0/0
C    200.30.1.0/24 is directly connected, FastEthernet0/1
B    192.168.10.0/24 [20/100] via 200.30.0.254, 01:38:22





AS30-ISP-RT#show bgp
BGP table version is 10, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       200.30.0.254           100             0 10 10 i
*> 2.2.2.2/32       200.30.0.254                           0 10 10 20 i
*> 3.3.3.3/32       0.0.0.0                  0         32768 i
*  100.0.0.0/24     200.30.0.254                           0 10 10 20 1000 i
*>                  200.30.1.1               0             0 1000 i
*> 192.168.10.0     200.30.0.254           100             0 10 10 i
*> 200.10.0.0       200.30.0.254           100             0 10 10 i
*> 200.20.0.0       200.30.0.254           100             0 10 10 i
r> 200.30.0.0       200.30.0.254           100             0 10 10 i






AS30-ISP-RT#show bgp all summary
For address family: IPv4 Unicast
BGP router identifier 3.3.3.3, local AS number 30
BGP table version is 10, main routing table version 10
8 network entries using 936 bytes of memory
9 path entries using 468 bytes of memory
6/4 BGP path/bestpath attribute entries using 744 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2244 total bytes of memory
BGP activity 8/0 prefixes, 9/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
200.30.0.254    4    10     245     243       10    0    0 01:59:10        7
200.30.1.1      4  1000     242     245       10    0    0 01:59:05        1






AS30-ISP-RT#show bgp all neighbors 200.30.0.254 routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       200.30.0.254           100             0 10 10 i
*> 2.2.2.2/32       200.30.0.254                           0 10 10 20 i
*  100.0.0.0/24     200.30.0.254                           0 10 10 20 1000 i
*> 192.168.10.0     200.30.0.254           100             0 10 10 i
*> 200.10.0.0       200.30.0.254           100             0 10 10 i
*> 200.20.0.0       200.30.0.254           100             0 10 10 i
r> 200.30.0.0       200.30.0.254           100             0 10 10 i

Total number of prefixes 7






AS30-ISP-RT#show bgp all neighbors 200.30.0.254 received-routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       200.30.0.254           100             0 10 10 i
*> 2.2.2.2/32       200.30.0.254                           0 10 10 20 i
*  100.0.0.0/24     200.30.0.254                           0 10 10 20 1000 i
*> 192.168.10.0     200.30.0.254           100             0 10 10 i
*> 200.10.0.0       200.30.0.254           100             0 10 10 i
*> 200.20.0.0       200.30.0.254           100             0 10 10 i
r> 200.30.0.0       200.30.0.254           100             0 10 10 i

Total number of prefixes 7






AS30-ISP-RT#show bgp all neighbors 200.30.0.254 advertised-routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 3.3.3.3/32       0.0.0.0                  0         32768 i
*> 100.0.0.0/24     200.30.1.1               0             0 1000 i

Total number of prefixes 2






AS30-ISP-RT#show bgp all neighbors 200.30.1.1 routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 100.0.0.0/24     200.30.1.1               0             0 1000 i

Total number of prefixes 1






AS30-ISP-RT#show bgp all neighbors 200.30.1.1 received-routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 100.0.0.0/24     200.30.1.1               0             0 1000 i

Total number of prefixes 1






AS30-ISP-RT#show bgp all neighbors 200.30.1.1 advertised-routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       200.30.0.254           100             0 10 10 i
*> 2.2.2.2/32       200.30.0.254                           0 10 10 20 i
*> 3.3.3.3/32       0.0.0.0                  0         32768 i
*> 192.168.10.0     200.30.0.254           100             0 10 10 i
*> 200.10.0.0       200.30.0.254           100             0 10 10 i
*> 200.20.0.0       200.30.0.254           100             0 10 10 i
r> 200.30.0.0       200.30.0.254           100             0 10 10 i

Total number of prefixes 7




・AS1000-RT-1
AS1000-RT-1

AS1000-RT-1#show running-config
Building configuration...

Current configuration : 6023 bytes
!
version 12.4
service timestamps debug datetime localtime
service timestamps log datetime localtime
no service password-encryption
!
hostname AS1000-RT-1
!
boot-start-marker
boot-end-marker
!
enable secret admin
!
no aaa new-model
memory-size iomem 5
clock timezone JST 9
no ip source-route
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username admin password admin
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface Loopback0
 ip address 100.0.0.1 255.255.255.255
!
interface FastEthernet0/0
 description to_AS20-ISP-RT
 ip address 200.20.1.1 255.255.255.0
 ip access-group AL_from-The-Internet in
 ip access-group AL_to-The-Internet out
 no ip redirects
 no ip proxy-arp
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description to_AS1000-ERT-2
 ip address 100.0.0.33 255.255.255.252
 no ip redirects
 no ip proxy-arp
 duplex auto
 speed auto
!
interface FastEthernet1/0
 description to_AS65412-RT
 switchport access vlan 10
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address 100.0.0.126 255.255.255.192
 no ip redirects
 no ip proxy-arp
!
router bgp 1000
 bgp router-id 100.0.0.1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 bgp maxas-limit 100
 timers bgp 30 90
 neighbor PEER-GROUP-RT peer-group
 neighbor PEER-GROUP-RT remote-as 65412
 neighbor 100.0.0.34 remote-as 1000
 neighbor 100.0.0.34 description AS1000-ERT-2
 neighbor 100.0.0.65 peer-group PEER-GROUP-RT
 neighbor 200.20.1.254 remote-as 20
 neighbor 200.20.1.254 description AS20-ISP-RT
 !
 address-family ipv4
  neighbor PEER-GROUP-RT default-originate
  neighbor PEER-GROUP-RT prefix-list PL_from-Router in
  neighbor PEER-GROUP-RT prefix-list PL_to-Router out
  neighbor 100.0.0.34 activate
  neighbor 100.0.0.65 activate
  neighbor 200.20.1.254 activate
  neighbor 200.20.1.254 soft-reconfiguration inbound
  neighbor 200.20.1.254 prefix-list PL_from-ISP in
  neighbor 200.20.1.254 prefix-list PL_to-ISP out
  neighbor 200.20.1.254 filter-list 100 out
  no auto-summary
  no synchronization
  network 100.0.0.0 mask 255.255.255.0
 exit-address-family
!
no ip http server
no ip http secure-server
ip forward-protocol nd
ip route 100.0.0.0 255.255.255.0 Null0
ip route 200.30.1.0 255.255.255.0 100.0.0.34
!
!
ip as-path access-list 100 permit ^$
!
!
ip prefix-list PL_from-ISP seq 10 deny 0.0.0.0/0
ip prefix-list PL_from-ISP seq 20 deny 0.0.0.0/8 le 32
ip prefix-list PL_from-ISP seq 30 deny 10.0.0.0/8 le 32
ip prefix-list PL_from-ISP seq 40 deny 172.16.0.0/12 le 32
ip prefix-list PL_from-ISP seq 50 deny 192.168.0.0/16 le 32
ip prefix-list PL_from-ISP seq 60 deny 127.0.0.0/8 le 32
ip prefix-list PL_from-ISP seq 70 deny 169.254.0.0/16 le 32
ip prefix-list PL_from-ISP seq 80 deny 224.0.0.0/3 le 32
ip prefix-list PL_from-ISP seq 90 deny 100.0.0.0/24 le 32
ip prefix-list PL_from-ISP seq 999 permit 0.0.0.0/0 le 32
!
ip prefix-list PL_from-Router seq 10 permit 100.0.0.3/32
ip prefix-list PL_from-Router seq 20 permit 100.0.0.128/25 le 32
ip prefix-list PL_from-Router seq 999 deny 0.0.0.0/0 le 32
!
ip prefix-list PL_to-ISP seq 10 permit 100.0.0.0/24
ip prefix-list PL_to-ISP seq 999 deny 0.0.0.0/0 le 32
!
ip prefix-list PL_to-Router seq 10 permit 0.0.0.0/0
ip prefix-list PL_to-Router seq 999 deny 0.0.0.0/0 le 32
!
ip access-list extended AL_from-The-Internet
 deny   ip 0.0.0.0 0.0.0.255 any
 deny   ip 127.0.0.0 0.255.255.255 any
 deny   ip 169.254.0.0 0.0.255.255 any
 deny   ip 192.0.2.0 0.0.0.255 any
 deny   ip 224.0.0.0 15.255.255.255 any
 deny   ip 240.0.0.0 0.255.255.255 any
 deny   ip 10.0.0.0 0.255.255.255 any
 deny   ip 172.16.0.0 0.15.255.255 any
 deny   ip 192.168.0.0 0.0.255.255 any
 deny   ip 100.0.0.0 0.0.0.255 any
 deny   ip any 0.0.0.0 0.0.0.255
 deny   ip any 127.0.0.0 0.255.255.255
 deny   ip any 169.254.0.0 0.0.255.255
 deny   ip any 192.0.2.0 0.0.0.255
 deny   ip any 224.0.0.0 15.255.255.255
 deny   ip any 240.0.0.0 0.255.255.255
 deny   ip any 10.0.0.0 0.255.255.255
 deny   ip any 172.16.0.0 0.15.255.255
 deny   ip any 192.168.0.0 0.0.255.255
 permit ip any any
ip access-list extended AL_to-The-Internet
 deny   ip 0.0.0.0 0.0.0.255 any
 deny   ip 127.0.0.0 0.255.255.255 any
 deny   ip 169.254.0.0 0.0.255.255 any
 deny   ip 192.0.2.0 0.0.0.255 any
 deny   ip 224.0.0.0 15.255.255.255 any
 deny   ip 240.0.0.0 0.255.255.255 any
 deny   ip 10.0.0.0 0.255.255.255 any
 deny   ip 172.16.0.0 0.15.255.255 any
 deny   ip 192.168.0.0 0.0.255.255 any
 deny   ip any 0.0.0.0 0.0.0.255
 deny   ip any 127.0.0.0 0.255.255.255
 deny   ip any 169.254.0.0 0.0.255.255
 deny   ip any 192.0.2.0 0.0.0.255
 deny   ip any 224.0.0.0 15.255.255.255
 deny   ip any 240.0.0.0 0.255.255.255
 deny   ip any 10.0.0.0 0.255.255.255
 deny   ip any 172.16.0.0 0.15.255.255
 deny   ip any 192.168.0.0 0.0.255.255
 permit ip any any
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 login local
line aux 0
 exec-timeout 0 0
line vty 0 4
 exec-timeout 0 0
 logging synchronous
 login local
 transport input ssh telnet
!
!
end






AS1000-RT-1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
B       1.1.1.1 [20/0] via 200.20.1.254, 02:41:29
     2.0.0.0/32 is subnetted, 1 subnets
B       2.2.2.2 [20/0] via 200.20.1.254, 02:41:30
     100.0.0.0/8 is variably subnetted, 6 subnets, 5 masks
C       100.0.0.64/26 is directly connected, Vlan10
C       100.0.0.32/30 is directly connected, FastEthernet0/1
S       100.0.0.0/24 is directly connected, Null0
C       100.0.0.1/32 is directly connected, Loopback0
B       100.0.0.3/32 [20/0] via 100.0.0.65, 02:29:28
B       100.0.0.128/25 [20/0] via 100.0.0.65, 02:29:28
     3.0.0.0/32 is subnetted, 1 subnets
B       3.3.3.3 [200/0] via 200.30.1.254, 02:41:29
B    200.10.0.0/24 [20/0] via 200.20.1.254, 02:41:30
B    200.20.0.0/24 [20/0] via 200.20.1.254, 02:41:30
B    200.30.0.0/24 [20/0] via 200.20.1.254, 02:41:30
C    200.20.1.0/24 is directly connected, FastEthernet0/0
S    200.30.1.0/24 [1/0] via 100.0.0.34






AS1000-RT-1#show bgp
BGP table version is 12, local router ID is 100.0.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       200.20.1.254                           0 20 10 i
*> 2.2.2.2/32       200.20.1.254             0             0 20 i
*  3.3.3.3/32       200.20.1.254                           0 20 10 30 30 i
*>i                 200.30.1.254             0    100      0 30 i
* i100.0.0.0/24     100.0.0.34               0    100      0 i
*>                  0.0.0.0                  0         32768 i
*> 100.0.0.3/32     100.0.0.65               0             0 65412 i
* i                 100.0.0.65               0    100      0 65412 i
*> 100.0.0.128/25   100.0.0.65               0             0 65412 i
* i                 100.0.0.65               0    100      0 65412 i
*> 200.10.0.0       200.20.1.254                           0 20 10 i
*> 200.20.0.0       200.20.1.254                           0 20 10 i
*> 200.30.0.0       200.20.1.254                           0 20 10 i





AS1000-RT-1#show bgp all summary
For address family: IPv4 Unicast
BGP router identifier 100.0.0.1, local AS number 1000
BGP table version is 12, main routing table version 12
10 network entries using 1170 bytes of memory
14 path entries using 728 bytes of memory
9/5 BGP path/bestpath attribute entries using 1116 bytes of memory
5 BGP AS-PATH entries using 120 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
6 BGP filter-list cache entries using 72 bytes of memory
BGP using 3206 total bytes of memory
1 received paths for inbound soft reconfiguration
BGP activity 10/0 prefixes, 14/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
100.0.0.34      4  1000    3248    3249       12    0    0 02:42:08        4
100.0.0.65      4 65412     305     304       12    0    0 02:29:45        2
200.20.1.254    4    20     332     328       12    0    0 02:42:07        6





AS1000-RT-1#show bgp all neighbors 100.0.0.34 routes
For address family: IPv4 Unicast
BGP table version is 12, local router ID is 100.0.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i3.3.3.3/32       200.30.1.254             0    100      0 30 i
* i100.0.0.0/24     100.0.0.34               0    100      0 i
* i100.0.0.3/32     100.0.0.65               0    100      0 65412 i
* i100.0.0.128/25   100.0.0.65               0    100      0 65412 i

Total number of prefixes 4





AS1000-RT-1#show bgp all neighbors 100.0.0.34 received-routes
For address family: IPv4 Unicast
% Inbound soft reconfiguration not enabled on 100.0.0.34





AS1000-RT-1#show bgp all neighbors 100.0.0.34 advertised-routes
For address family: IPv4 Unicast
BGP table version is 12, local router ID is 100.0.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       200.20.1.254                           0 20 10 i
*> 2.2.2.2/32       200.20.1.254             0             0 20 i
*> 100.0.0.0/24     0.0.0.0                  0         32768 i
*> 100.0.0.3/32     100.0.0.65               0             0 65412 i
*> 100.0.0.128/25   100.0.0.65               0             0 65412 i
*> 200.10.0.0       200.20.1.254                           0 20 10 i
*> 200.20.0.0       200.20.1.254                           0 20 10 i
*> 200.30.0.0       200.20.1.254                           0 20 10 i

Total number of prefixes 8





AS1000-RT-1#show bgp all neighbors 100.0.0.65 routes
For address family: IPv4 Unicast
BGP table version is 12, local router ID is 100.0.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 100.0.0.3/32     100.0.0.65               0             0 65412 i
*> 100.0.0.128/25   100.0.0.65               0             0 65412 i

Total number of prefixes 2





AS1000-RT-1#show bgp all neighbors 100.0.0.65 received-routes
For address family: IPv4 Unicast
% Inbound soft reconfiguration not enabled on 100.0.0.65





AS1000-RT-1#show bgp all neighbors 100.0.0.65 advertised-routes
For address family: IPv4 Unicast
BGP table version is 12, local router ID is 100.0.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Originating default network 0.0.0.0

   Network          Next Hop            Metric LocPrf Weight Path

Total number of prefixes 0





AS1000-RT-1#show bgp all neighbors 200.20.1.254 routes
For address family: IPv4 Unicast
BGP table version is 12, local router ID is 100.0.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       200.20.1.254                           0 20 10 i
*> 2.2.2.2/32       200.20.1.254             0             0 20 i
*  3.3.3.3/32       200.20.1.254                           0 20 10 30 30 i
*> 200.10.0.0       200.20.1.254                           0 20 10 i
*> 200.20.0.0       200.20.1.254                           0 20 10 i
*> 200.30.0.0       200.20.1.254                           0 20 10 i

Total number of prefixes 6





AS1000-RT-1#show bgp all neighbors 200.20.1.254 received-routes
For address family: IPv4 Unicast
BGP table version is 12, local router ID is 100.0.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.1/32       200.20.1.254                           0 20 10 i
*> 2.2.2.2/32       200.20.1.254             0             0 20 i
*  3.3.3.3/32       200.20.1.254                           0 20 10 30 30 i
*  192.168.10.0     200.20.1.254                           0 20 10 i
*> 200.10.0.0       200.20.1.254                           0 20 10 i
*> 200.20.0.0       200.20.1.254                           0 20 10 i
*> 200.30.0.0       200.20.1.254                           0 20 10 i

Total number of prefixes 7





AS1000-RT-1#show bgp all neighbors 200.20.1.254 advertised-routes
For address family: IPv4 Unicast
BGP table version is 12, local router ID is 100.0.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 100.0.0.0/24     0.0.0.0                  0         32768 i

Total number of prefixes 1





・AS1000-RT-2
AS1000-RT-2

AS1000-RT-2#show running-config
Building configuration...

Current configuration : 6133 bytes
!
version 12.4
service timestamps debug datetime localtime
service timestamps log datetime localtime
no service password-encryption
!
hostname AS1000-RT-2
!
boot-start-marker
boot-end-marker
!
enable secret admin
!
no aaa new-model
memory-size iomem 5
clock timezone JST 9
no ip source-route
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username admin password admin
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface Loopback0
 ip address 100.0.0.2 255.255.255.255
!
interface FastEthernet0/0
 description to_AS30-ISP-RT
 ip address 200.30.1.1 255.255.255.0
 ip access-group AL_from-The-Internet in
 ip access-group AL_to-The-Internet out
 no ip redirects
 no ip proxy-arp
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description to_AS1000-ERT-1
 ip address 100.0.0.34 255.255.255.252
 no ip redirects
 no ip proxy-arp
 duplex auto
 speed auto
!
interface FastEthernet1/0
 description to_AS65412-RT
 switchport access vlan 10
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address 100.0.0.125 255.255.255.192
 no ip redirects
 no ip proxy-arp
!
router bgp 1000
 bgp router-id 100.0.0.2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 bgp maxas-limit 100
 timers bgp 30 90
 neighbor PEER-GROUP-RT peer-group
 neighbor PEER-GROUP-RT remote-as 65412
 neighbor 100.0.0.33 remote-as 1000
 neighbor 100.0.0.33 description AS1000-ERT-1
 neighbor 100.0.0.33 timers 3 9
 neighbor 100.0.0.65 peer-group PEER-GROUP-RT
 neighbor 200.30.1.254 remote-as 30
 neighbor 200.30.1.254 description AS30-ISP-RT
 !
 address-family ipv4
  neighbor PEER-GROUP-RT default-originate route-map RM_set-med-100
  neighbor PEER-GROUP-RT prefix-list PL_from-Router in
  neighbor PEER-GROUP-RT prefix-list PL_to-Router out
  neighbor 100.0.0.33 activate
  neighbor 100.0.0.65 activate
  neighbor 200.30.1.254 activate
  neighbor 200.30.1.254 soft-reconfiguration inbound
  neighbor 200.30.1.254 prefix-list PL_from-ISP in
  neighbor 200.30.1.254 prefix-list PL_to-ISP out
  neighbor 200.30.1.254 filter-list 100 out
  no auto-summary
  no synchronization
  network 100.0.0.0 mask 255.255.255.0
 exit-address-family
!
no ip http server
no ip http secure-server
ip forward-protocol nd
ip route 100.0.0.0 255.255.255.0 Null0
ip route 200.20.1.0 255.255.255.0 100.0.0.33
!
!
ip as-path access-list 100 permit ^$
!
!
ip prefix-list PL_from-ISP seq 10 deny 0.0.0.0/0
ip prefix-list PL_from-ISP seq 20 deny 0.0.0.0/8 le 32
ip prefix-list PL_from-ISP seq 30 deny 10.0.0.0/8 le 32
ip prefix-list PL_from-ISP seq 40 deny 172.16.0.0/12 le 32
ip prefix-list PL_from-ISP seq 50 deny 192.168.0.0/16 le 32
ip prefix-list PL_from-ISP seq 60 deny 127.0.0.0/8 le 32
ip prefix-list PL_from-ISP seq 70 deny 169.254.0.0/16 le 32
ip prefix-list PL_from-ISP seq 80 deny 224.0.0.0/3 le 32
ip prefix-list PL_from-ISP seq 90 deny 100.0.0.0/24 le 32
ip prefix-list PL_from-ISP seq 999 permit 0.0.0.0/0 le 32
!
ip prefix-list PL_from-Router seq 10 permit 100.0.0.3/32
ip prefix-list PL_from-Router seq 20 permit 100.0.0.128/25 le 32
ip prefix-list PL_from-Router seq 999 deny 0.0.0.0/0 le 32
!
ip prefix-list PL_to-ISP seq 10 permit 100.0.0.0/24
ip prefix-list PL_to-ISP seq 999 deny 0.0.0.0/0 le 32
!
ip prefix-list PL_to-Router seq 10 permit 0.0.0.0/0
ip prefix-list PL_to-Router seq 999 deny 0.0.0.0/0 le 32
!
ip access-list extended AL_from-The-Internet
 deny   ip 0.0.0.0 0.0.0.255 any
 deny   ip 127.0.0.0 0.255.255.255 any
 deny   ip 169.254.0.0 0.0.255.255 any
 deny   ip 192.0.2.0 0.0.0.255 any
 deny   ip 224.0.0.0 15.255.255.255 any
 deny   ip 240.0.0.0 0.255.255.255 any
 deny   ip 10.0.0.0 0.255.255.255 any
 deny   ip 172.16.0.0 0.15.255.255 any
 deny   ip 192.168.0.0 0.0.255.255 any
 deny   ip 100.0.0.0 0.0.0.255 any
 deny   ip any 0.0.0.0 0.0.0.255
 deny   ip any 127.0.0.0 0.255.255.255
 deny   ip any 169.254.0.0 0.0.255.255
 deny   ip any 192.0.2.0 0.0.0.255
 deny   ip any 224.0.0.0 15.255.255.255
 deny   ip any 240.0.0.0 0.255.255.255
 deny   ip any 10.0.0.0 0.255.255.255
 deny   ip any 172.16.0.0 0.15.255.255
 deny   ip any 192.168.0.0 0.0.255.255
 permit ip any any
ip access-list extended AL_to-The-Internet
 deny   ip 0.0.0.0 0.0.0.255 any
 deny   ip 127.0.0.0 0.255.255.255 any
 deny   ip 169.254.0.0 0.0.255.255 any
 deny   ip 192.0.2.0 0.0.0.255 any
 deny   ip 224.0.0.0 15.255.255.255 any
 deny   ip 240.0.0.0 0.255.255.255 any
 deny   ip 10.0.0.0 0.255.255.255 any
 deny   ip 172.16.0.0 0.15.255.255 any
 deny   ip 192.168.0.0 0.0.255.255 any
 deny   ip any 0.0.0.0 0.0.0.255
 deny   ip any 127.0.0.0 0.255.255.255
 deny   ip any 169.254.0.0 0.0.255.255
 deny   ip any 192.0.2.0 0.0.0.255
 deny   ip any 224.0.0.0 15.255.255.255
 deny   ip any 240.0.0.0 0.255.255.255
 deny   ip any 10.0.0.0 0.255.255.255
 deny   ip any 172.16.0.0 0.15.255.255
 deny   ip any 192.168.0.0 0.0.255.255
 permit ip any any
no cdp log mismatch duplex
!
route-map RM_set-med-100 permit 10
 set metric 100
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 login local
line aux 0
 exec-timeout 0 0
line vty 0 4
 exec-timeout 0 0
 logging synchronous
 login local
 transport input ssh telnet
!
!
end






AS1000-RT-2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
B       1.1.1.1 [200/0] via 200.20.1.254, 02:50:36
     2.0.0.0/32 is subnetted, 1 subnets
B       2.2.2.2 [200/0] via 200.20.1.254, 02:50:36
     100.0.0.0/8 is variably subnetted, 6 subnets, 5 masks
C       100.0.0.64/26 is directly connected, Vlan10
C       100.0.0.32/30 is directly connected, FastEthernet0/1
S       100.0.0.0/24 is directly connected, Null0
C       100.0.0.2/32 is directly connected, Loopback0
B       100.0.0.3/32 [20/0] via 100.0.0.65, 02:39:06
B       100.0.0.128/25 [20/0] via 100.0.0.65, 02:39:06
     3.0.0.0/32 is subnetted, 1 subnets
B       3.3.3.3 [20/0] via 200.30.1.254, 02:50:36
B    200.10.0.0/24 [200/0] via 200.20.1.254, 02:50:36
B    200.20.0.0/24 [200/0] via 200.20.1.254, 02:50:36
B    200.30.0.0/24 [200/0] via 200.20.1.254, 02:50:36
S    200.20.1.0/24 [1/0] via 100.0.0.33
C    200.30.1.0/24 is directly connected, FastEthernet0/0





AS1000-RT-2#show bgp
BGP table version is 10, local router ID is 100.0.0.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*  1.1.1.1/32       200.30.1.254                           0 30 10 10 i
*>i                 200.20.1.254             0    100      0 20 10 i
*  2.2.2.2/32       200.30.1.254                           0 30 10 10 20 i
*>i                 200.20.1.254             0    100      0 20 i
*> 3.3.3.3/32       200.30.1.254             0             0 30 i
* i100.0.0.0/24     100.0.0.33               0    100      0 i
*>                  0.0.0.0                  0         32768 i
* i100.0.0.3/32     100.0.0.65               0    100      0 65412 i
*>                  100.0.0.65               0             0 65412 i
* i100.0.0.128/25   100.0.0.65               0    100      0 65412 i
*>                  100.0.0.65               0             0 65412 i
*  200.10.0.0       200.30.1.254                           0 30 10 10 i
*>i                 200.20.1.254             0    100      0 20 10 i
*  200.20.0.0       200.30.1.254                           0 30 10 10 i
*>i                 200.20.1.254             0    100      0 20 10 i
*  200.30.0.0       200.30.1.254                           0 30 10 10 i
*>i                 200.20.1.254             0    100      0 20 10 i





AS1000-RT-2#show bgp all summary
For address family: IPv4 Unicast
BGP router identifier 100.0.0.2, local AS number 1000
BGP table version is 10, main routing table version 10
10 network entries using 1170 bytes of memory
18 path entries using 936 bytes of memory
10/5 BGP path/bestpath attribute entries using 1240 bytes of memory
6 BGP AS-PATH entries using 144 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
5 BGP filter-list cache entries using 60 bytes of memory
BGP using 3550 total bytes of memory
1 received paths for inbound soft reconfiguration
BGP activity 10/0 prefixes, 18/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
100.0.0.33      4  1000    3432    3431       10    0    0 02:51:17        8
100.0.0.65      4 65412     325     323       10    0    0 02:39:10        2
200.30.1.254    4    30     349     346       10    0    0 02:51:11        6





AS1000-RT-2#show bgp all neighbors 100.0.0.33 routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 100.0.0.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i1.1.1.1/32       200.20.1.254             0    100      0 20 10 i
*>i2.2.2.2/32       200.20.1.254             0    100      0 20 i
* i100.0.0.0/24     100.0.0.33               0    100      0 i
* i100.0.0.3/32     100.0.0.65               0    100      0 65412 i
* i100.0.0.128/25   100.0.0.65               0    100      0 65412 i
*>i200.10.0.0       200.20.1.254             0    100      0 20 10 i
*>i200.20.0.0       200.20.1.254             0    100      0 20 10 i
*>i200.30.0.0       200.20.1.254             0    100      0 20 10 i

Total number of prefixes 8





AS1000-RT-2#show bgp all neighbors 100.0.0.33 received-routes
For address family: IPv4 Unicast
% Inbound soft reconfiguration not enabled on 100.0.0.33





AS1000-RT-2#show bgp all neighbors 100.0.0.33 advertised-routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 100.0.0.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 3.3.3.3/32       200.30.1.254             0             0 30 i
*> 100.0.0.0/24     0.0.0.0                  0         32768 i
*> 100.0.0.3/32     100.0.0.65               0             0 65412 i
*> 100.0.0.128/25   100.0.0.65               0             0 65412 i

Total number of prefixes 4





AS1000-RT-2#show bgp all neighbors 100.0.0.65 routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 100.0.0.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 100.0.0.3/32     100.0.0.65               0             0 65412 i
*> 100.0.0.128/25   100.0.0.65               0             0 65412 i

Total number of prefixes 2





AS1000-RT-2#show bgp all neighbors 100.0.0.65 received-routes
For address family: IPv4 Unicast
% Inbound soft reconfiguration not enabled on 100.0.0.65





AS1000-RT-2#show bgp all neighbors 100.0.0.65 advertised-routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 100.0.0.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Originating default network 0.0.0.0

   Network          Next Hop            Metric LocPrf Weight Path

Total number of prefixes 0





AS1000-RT-2#show bgp all neighbors 200.30.1.254 routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 100.0.0.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*  1.1.1.1/32       200.30.1.254                           0 30 10 10 i
*  2.2.2.2/32       200.30.1.254                           0 30 10 10 20 i
*> 3.3.3.3/32       200.30.1.254             0             0 30 i
*  200.10.0.0       200.30.1.254                           0 30 10 10 i
*  200.20.0.0       200.30.1.254                           0 30 10 10 i
*  200.30.0.0       200.30.1.254                           0 30 10 10 i

Total number of prefixes 6





AS1000-RT-2#show bgp all neighbors 200.30.1.254 received-routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 100.0.0.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*  1.1.1.1/32       200.30.1.254                           0 30 10 10 i
*  2.2.2.2/32       200.30.1.254                           0 30 10 10 20 i
*> 3.3.3.3/32       200.30.1.254             0             0 30 i
*  192.168.10.0     200.30.1.254                           0 30 10 10 i
*  200.10.0.0       200.30.1.254                           0 30 10 10 i
*  200.20.0.0       200.30.1.254                           0 30 10 10 i
*  200.30.0.0       200.30.1.254                           0 30 10 10 i

Total number of prefixes 7





AS1000-RT-2#show bgp all neighbors 200.30.1.254 advertised-routes
For address family: IPv4 Unicast
BGP table version is 10, local router ID is 100.0.0.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 100.0.0.0/24     0.0.0.0                  0         32768 i

Total number of prefixes 1





・AS65412-RT
AS65412-RT

AS65412-RT#show running-config
Building configuration...

Current configuration : 2840 bytes
!
version 12.4
service timestamps debug datetime localtime
service timestamps log datetime localtime
no service password-encryption
!
hostname AS65412-RT
!
boot-start-marker
boot-end-marker
!
enable secret admin
!
no aaa new-model
memory-size iomem 5
clock timezone JST 9
no ip source-route
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username admin password admin
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface Loopback0
 ip address 100.0.0.3 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 description to_AS1000-RT-1
 switchport access vlan 10
!
interface FastEthernet1/1
 description to_AS1000-RT-2
 switchport access vlan 10
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
 description to_PC
 no switchport
 ip address 100.0.0.254 255.255.255.128
 no ip redirects
 no ip proxy-arp
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address 100.0.0.65 255.255.255.192
 no ip redirects
 no ip proxy-arp
!
router bgp 65412
 bgp router-id 100.0.0.3
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 timers bgp 30 90
 neighbor 100.0.0.125 remote-as 1000
 neighbor 100.0.0.125 description AS1000-ERT-2
 neighbor 100.0.0.126 remote-as 1000
 neighbor 100.0.0.126 description AS1000-ERT-1
 !
 address-family ipv4
  neighbor 100.0.0.125 activate
  neighbor 100.0.0.126 activate
  no auto-summary
  no synchronization
  network 100.0.0.3 mask 255.255.255.255
  network 100.0.0.128 mask 255.255.255.128
 exit-address-family
!
no ip http server
no ip http secure-server
ip forward-protocol nd
!
!
!
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 login local
line aux 0
 exec-timeout 0 0
line vty 0 4
 exec-timeout 0 0
 logging synchronous
 login local
 transport input ssh telnet
!
!
end






AS65412-RT#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 100.0.0.126 to network 0.0.0.0

     100.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
C       100.0.0.64/26 is directly connected, Vlan10
C       100.0.0.3/32 is directly connected, Loopback0
C       100.0.0.128/25 is directly connected, FastEthernet1/10
B*   0.0.0.0/0 [20/0] via 100.0.0.126, 02:43:39





AS65412-RT#show bgp
BGP table version is 5, local router ID is 100.0.0.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 0.0.0.0          100.0.0.126              0             0 1000 i
*                   100.0.0.125            100             0 1000 i
*> 100.0.0.3/32     0.0.0.0                  0         32768 i
*> 100.0.0.128/25   0.0.0.0                  0         32768 i





AS65412-RT#show bgp all summary
For address family: IPv4 Unicast
BGP router identifier 100.0.0.3, local AS number 65412
BGP table version is 5, main routing table version 5
3 network entries using 351 bytes of memory
4 path entries using 208 bytes of memory
4/2 BGP path/bestpath attribute entries using 496 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1079 total bytes of memory
BGP activity 3/0 prefixes, 4/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
100.0.0.125     4  1000     332     334        5    0    0 02:43:58        1
100.0.0.126     4  1000     332     333        5    0    0 02:43:42        1





AS65412-RT#show bgp all neighbors 100.0.0.125 routes
For address family: IPv4 Unicast
BGP table version is 5, local router ID is 100.0.0.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*  0.0.0.0          100.0.0.125            100             0 1000 i

Total number of prefixes 1





AS65412-RT#show bgp all neighbors 100.0.0.125 received-routes
For address family: IPv4 Unicast
% Inbound soft reconfiguration not enabled on 100.0.0.125





AS65412-RT#show bgp all neighbors 100.0.0.125 advertised-routes
For address family: IPv4 Unicast
BGP table version is 5, local router ID is 100.0.0.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 0.0.0.0          100.0.0.126              0             0 1000 i
*> 100.0.0.3/32     0.0.0.0                  0         32768 i
*> 100.0.0.128/25   0.0.0.0                  0         32768 i

Total number of prefixes 3





AS65412-RT#show bgp all neighbors 100.0.0.126 routes
For address family: IPv4 Unicast
BGP table version is 5, local router ID is 100.0.0.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 0.0.0.0          100.0.0.126              0             0 1000 i

Total number of prefixes 1





AS65412-RT#show bgp all neighbors 100.0.0.126 received-routes
For address family: IPv4 Unicast
% Inbound soft reconfiguration not enabled on 100.0.0.126





AS65412-RT#show bgp all neighbors 100.0.0.126 advertised-routes
For address family: IPv4 Unicast
BGP table version is 5, local router ID is 100.0.0.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 0.0.0.0          100.0.0.126              0             0 1000 i
*> 100.0.0.3/32     0.0.0.0                  0         32768 i
*> 100.0.0.128/25   0.0.0.0                  0         32768 i

Total number of prefixes 3



その他

・sh runに載らない(または暗号化される)けど設定しているもの
※装置により要調整

line con 0
 no privilege level
line aux 0
 no logging synchronous
 no privilege level
!



・AS1000-RT-1, AS1000-RT-1, AS65412-RT 間で通信出来ないなぁ。っと思ってたら、Vlan10を使ってるのにvlan database設定を忘れてました。。。。

#show vlan-switch
#vlan database
(vlan)#vlan 10 name NaibuNetwork

(vlan)#exit
 ・設定を保存してデータベースを抜ける

(vlan)#abort
 ・設定を保存しないでデータベースから抜ける



・BGPとOSPFを動かす場合に、タイマー値の違いからブラックホールが発生することがある。そのため、OSPFへ追加設定が必要。

router ospf 1
 max-metric router-lsa on-startup wait-for-bgp

こちらがとても参考になりました。
http://stereocat.hatenablog.com/entry/20120729/1343553348



以上です。

2
2
0

Register as a new user and use Qiita more conveniently

  1. You get articles that match your needs
  2. You can efficiently read back useful information
  3. You can use dark theme
What you can do with signing up
2
2