Ruby
archLinux
rbenv

Arch Linuxで古いRubyをrbenv installしようとすると失敗する

普通に rbenv install 2.3.0 すると失敗する

解決

pacaur -S gcc-6 openssl-1.0
wget https://archive.archlinux.org/packages/o/openssl/openssl-1.0.2.k-1-x86_64.pkg.tar.xz
tar xf openssl-1.0.2.k-1-x86_64.pkg.tar.xz
CC=/usr/bin/gcc-6 RUBY_CONFIGURE_OPTS=--with-openssl-dir=$PWD/openssl-1.0.2.k/usr rbenv install 2.3.0