PHP
Composer
laravel5.2
laravel-debugbar
laravel5.5

Laravel5.2備忘録 : Laravel Debugbar の導入

Laravel Debugbar のシステム要件

Laravel Debugbar には以下のシステム要件がある ( 2017/12/03 現在 ) ため, Laravel5.2 を使用している場合は V2.4 を導入する必要がある。最新のシステム要件は 公式サイト で要確認。

Laravel Debugbar Laravel
V3.1 Laravel5.5 以上
V2.4 Laravel5.0 以上 Laravel5.5 未満

composer で Laravel Debugbar を導入

Laravel5.2 の場合

インストールコマンド
composer require barryvdh/laravel-debugbar:~2.4

Laravel5.0 以上の場合

インストールコマンド
composer require barryvdh/laravel-debugbar

サービスプロバイダとエイリアスの追加

config/app.php に以下の設定を追加。

app.phpより抜粋
'providers' => [

    /*
     * Laravel Framework Service Providers...
     */
    Illuminate\Auth\AuthServiceProvider::class,
    // ...
    Illuminate\View\ViewServiceProvider::class,
+   Barryvdh\Debugbar\ServiceProvider::class,
    // ...

'aliases' => [

    'App'       => Illuminate\Support\Facades\App::class,
    // ...
    'View'      => Illuminate\Support\Facades\View::class,
+   'Debugbar'  => Barryvdh\Debugbar\Facade::class,
    // ...

参考サイト