Kotlin設定でエラー → Error:Failed to resolve: org.jetbrains.kotlin:kotlin-stdlib-jre7:1.0.7

More than 1 year has passed since last update.

Androidプロジェクトを新規作成し「Configure Kotlin in Project」でKotlin設定後ビルドをしたら下記エラーが出ました。

Kobito.8b60fw.png

これは単純に、kotlin-stdlib-jre7はバージョン1.1系以上のパッケージしか公開されていないためです。

https://mvnrepository.com/artifact/org.jetbrains.kotlin/kotlin-stdlib-jre7

ですので、バージョンを1.1以上のものにすれば直ります。


build.gradle

buildscript {

- ext.kotlin_version = '1.0.7'
+ ext.kotlin_version = '1.1.1'

...


参考:http://stackoverflow.com/q/42843441