Qiita Teams that are logged in
You are not logged in to any team

Log in to Qiita Team
Community
OrganizationAdvent CalendarQiitadon (β)
Service
Qiita JobsQiita ZineQiita Blog
Help us understand the problem. What is going on with this article?

Nuxt.jsでpostcss-simple-varsを使用したい場合

Postcss-8のプラグインが必要で行き詰まってる方へ

使用バージョン

Nuxt 2.14.5

package.json
{
  "dependencies": {
    "core-js": "^3.6.5",
    "nuxt": "^2.14.6"
  },
  "devDependencies": {
    "postcss-simple-vars": "^6.0.1"
  }
}

postcss-simple-varsの最新バージョンは^6.0.1です

しかしNuxt.jsではPostcss8が現在動作しません。
https://github.com/postcss/postcss/wiki/PostCSS-8-for-end-users

なので

package.json
{
  "dependencies": {
    "core-js": "^3.6.5",
    "nuxt": "^2.14.6"
  },
  "devDependencies": {
    "postcss-simple-vars": "^5.0.2"
  }
}

postcss-simple-varsのバージョンを下げます

他のプラグインも同様に、一年ほど前のプラグインのバージョンに下げると使用することができました。

これでpostcss-simple-varsを使用できるはずです。

今後Nuxt.jsもPostcss 8に対応されるはずなので、公式情報を見張っておきましょう!

引用

PostCSS 8 for end users

Why not register and get more from Qiita?
  1. We will deliver articles that match you
    By following users and tags, you can catch up information on technical fields that you are interested in as a whole
  2. you can read useful information later efficiently
    By "stocking" the articles you like, you can search right away