Edited at

libpq-fe.h が見つけられない。

More than 3 years have passed since last update.


起こった問題

Amazon LinuxでPosgreSQLに接続用gemのpgをインストールしていると、以下のようなエラーが吐かれました。

$ gem install pg

Building native extensions. This could take a while...
ERROR: Error installing pg:
ERROR: Failed to build gem native extension.

/home/username/.rbenv/versions/2.1.1/bin/ruby extconf.rb
checking for pg_config... yes
Using config values from /usr/bin/pg_config
checking for libpq-fe.h... no
Can't find the 'libpq-fe.h header
*** extconf.rb failed ***


解決法

以下のコマンド一発です。

$ sudo yum install postgresql-devel


さいごに

簡単なことですが、Web上に情報が見当たらなかったので書き残しておきます。