gem install libv8 に失敗する。

  • 111
    いいね
  • 2
    コメント
この記事は最終更新日から1年以上が経過しています。

2014-11-19 追記

「Mavericksにしたらrails sやbundle installが出来なくなった。」というタイトルで公開していましたが、Yosemiteでも同じことが起こるみたいなのでタイトルを変更しました。

概要

  1. Mavericksを入れた。
  2. rails sbundle installが通らない。
  3. 俺氏涙目(´;ω;`)

起こったこと(1)

Mavericksにアップグレードしてrails sしたところ、次のエラーが発生しました。

$ rails s
Could not find libv8-3.11.8.17 in any of the sources
Run `bundle install` to install missing gems.

起こったこと(2)

言われたとおりに、bundle installしたところ、次のエラーが発生しました。
長いですが、ほぼ全文載せておきます。

$ bundle install
Installing libv8 (3.11.8.17)
Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.

    /Users/user/.rbenv/versions/2.0.0-p247/bin/ruby extconf.rb
creating Makefile
Compiling v8 for x64
Using python 2.7.5
Configured with: --prefix=/Applications/Xcode.app/Contents/Developer/usr --with-gxx-include-dir=/usr/include/c++/4.2.1
Unable to find a compiler officially supported by v8.
It is recommended to use GCC v4.4 or higher
Using compiler: g++
Configured with: --prefix=/Applications/Xcode.app/Contents/Developer/usr --with-gxx-include-dir=/usr/include/c++/4.2.1
Unable to find a compiler officially supported by v8.
It is recommended to use GCC v4.4 or higher
/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/libtool: file: /Users/user/.rbenv/versions/2.0.0-p247/lib/ruby/gems/2.0.0/gems/libv8-3.11.8.17/vendor/v8/out/x64.release/obj.target/preparser_lib/src/atomicops_internals_x86_gcc.o has no symbols
In file included from ../src/accessors.cc:28:
In file included from ../src/v8.h:60:
In file included from ../src/objects-inl.h:38:
In file included from ../src/elements.h:33:
In file included from ../src/heap.h:41:
../src/store-buffer.h:229:9: error: private field 'heap_' is not used [-Werror,-Wunused-private-field]
  Heap* heap_;
        ^
1 error generated.
make[1]: *** [/Users/user/.rbenv/versions/2.0.0-p247/lib/ruby/gems/2.0.0/gems/libv8-3.11.8.17/vendor/v8/out/x64.release/obj.target/v8_base/src/accessors.o] Error 1
make: *** [x64.release] Error 2
/Users/user/.rbenv/versions/2.0.0-p247/lib/ruby/gems/2.0.0/gems/libv8-3.11.8.17/ext/libv8/location.rb:36:in `block in verify_installation!': libv8 did not install properly, expected binary v8 archive '/Users/user/.rbenv/versions/2.0.0-p247/lib/ruby/gems/2.0.0/gems/libv8-3.11.8.17/vendor/v8/out/x64.release/obj.target/tools/gyp/libv8_base.a'to exist, but it was not found (Libv8::Location::Vendor::ArchiveNotFound)
    from /Users/user/.rbenv/versions/2.0.0-p247/lib/ruby/gems/2.0.0/gems/libv8-3.11.8.17/ext/libv8/location.rb:35:in `each'
    from /Users/user/.rbenv/versions/2.0.0-p247/lib/ruby/gems/2.0.0/gems/libv8-3.11.8.17/ext/libv8/location.rb:35:in `verify_installation!'
    from /Users/user/.rbenv/versions/2.0.0-p247/lib/ruby/gems/2.0.0/gems/libv8-3.11.8.17/ext/libv8/location.rb:26:in `install!'
    from extconf.rb:7:in `<main>'
GYP_GENERATORS=make \
    build/gyp/gyp --generator-output="out" build/all.gyp \
                  -Ibuild/standalone.gypi --depth=. \
                  -Dv8_target_arch=x64 \
                  -S.x64  -Dv8_can_use_vfp_instructions=true
  CXX(target) /Users/user/.rbenv/versions/2.0.0-p247/lib/ruby/gems/2.0.0/gems/libv8-3.11.8.17/vendor/v8/out/x64.release/obj.target/preparser_lib/src/allocation.o
  LIBTOOL-STATIC /Users/user/.rbenv/versions/2.0.0-p247/lib/ruby/gems/2.0.0/gems/libv8-3.11.8.17/vendor/v8/out/x64.release/libpreparser_lib.a
  LINK(target) /Users/user/.rbenv/versions/2.0.0-p247/lib/ruby/gems/2.0.0/gems/libv8-3.11.8.17/vendor/v8/out/x64.release/preparser
  CXX(target) /Users/user/.rbenv/versions/2.0.0-p247/lib/ruby/gems/2.0.0/gems/libv8-3.11.8.17/vendor/v8/out/x64.release/obj.target/v8_base/src/accessors.o

Gem files will remain installed in /Users/user/.rbenv/versions/2.0.0-p247/lib/ruby/gems/2.0.0/gems/libv8-3.11.8.17 for inspection.
Results logged to /Users/user/.rbenv/versions/2.0.0-p247/lib/ruby/gems/2.0.0/gems/libv8-3.11.8.17/ext/libv8/gem_make.out

An error occurred while installing libv8 (3.11.8.17), and Bundler cannot continue.
Make sure that `gem install libv8 -v '3.11.8.17'` succeeds before bundling.

ちなみに、gem install libv8 -v '3.11.8.17'しても、同様のエラーが吐かれます。

解決法

gem installにオプションを渡してあげるだけです。

$ gem install libv8 -v '3.11.8.17' -- --with-system-v8

これでrails sが通るようになりました。