This request has already been treated.

  1. kaibadash@github
Changes in title
-[PHPStorm] 使用するPHPのバージョンの設定を変更する
+[PhpStorm] 使用するPHPのバージョンの設定を変更する
Changes in body
Source | HTML | Preview
@@ -1,28 +1,28 @@
-# PHPStorm で PHP のバージョンを指定する
+# PhpStorm で PHP のバージョンを指定する
PHPのどのバージョンでコードを書いていて、
チェックをさせるかの設定を変更する方法。
# 経緯
PHP7.1 でコードを書くようになったが、
PHP7 の記法がエラー扱いになっていたので設定を変更した。
# PHPStorm
1. Preferences を開く
2. Languages&Frameworks の項目を開く
3. PHP を選択
4. PHP language level を お好みのバージョンを選択する
5. 設定完了する
### PHP language levelが変更できない場合
1. Preferences を開く
2. Languages&Frameworks の項目を開く
3. PHP の項目を開く
4. composer を選択
5. Synchronize IDE settings with composer.json のチェックを外す
6. 設定完了する
設定後、PHP language level を変更できるようになる。