TravisCIでubuntu14.04向けのパッケージをインストールする方法

More than 3 years have passed since last update.


TravisCIのOS


  • デフォルトではUbuntu 12.04

  • なのでapt-getでパッケージを取得する場合に、「あれ、インストールされたバージョンが古い!」ということもある

  • そのため、最新のパッケージを取得するにはadd-apt-repositoryをしてやらねばならない

  • ちなみに、最新のバージョン指定して取得してみても見つかりませんといわれました(12.04なのでというオチ)


対応


  • .travis.ymlに以下を追記するだけ


.travis.yml

...

before_install:
- sudo add-apt-repository -y "deb http://archive.ubuntu.com/ubuntu/ trusty main universe"
- sudo apt-get update -qq
...


~ただの宣伝~


  • 全国のSeleniumer必読

  • Seleniumerといっていますが、Selenium, SauceLabs, Travis, Jenkinsに関するノウハウ書いているのでよかったら参考にしてみてください