Posted at

"Could not find url for MSVC version = 1700 and Python version = 2.7."の対処法

More than 1 year has passed since last update.

Caffe for Windowsのビルド時に以下のエラーが発生してハマったのでメモ。


エラー内容

The specified configuration type is missing. The tools for the configuration might not be installed.

CMake Error at cmake/WindowsDownloadPrebuiltDependencies.cmake:40 (message):
Could not find url for MSVC version = 1700 and Python version = 2.7.
Call Stack (most recent call first):
CMakeLists.txt:77 (include)

-- Configuring incomplete, errors occurred!
ERROR: Configure failed


対処法

Caffe(あるいはCMake)はVS2012でのビルドには対応してないそうです。

なので、VS2013かVS2015(あるいはそれ以降のバージョン)をインストールしましょう…