Qiita Teams that are logged in
You are not logged in to any team

Log in to Qiita Team
Community
OrganizationEventAdvent CalendarQiitadon (β)
Service
Qiita JobsQiita ZineQiita Blog
0
Help us understand the problem. What are the problem?

RouterOSでフレッツのv6プラス(MAP-E)を利用する

何故か分からないのだけど、うまく動いてしまったようなので…。
速報的な記事です。

前提

  • RouterOS v7.1 beta6 (CHR版)
  • CE-BR間のトンネル設定が済んでおり割り当てられたポートで通信が可能であること
  • v6プラス環境 (OCNバーチャルコネクトではない)

設定

こちらのブログ記事を参考にさせていただきました。

RouterOS上で下記スクリプトを実行し、設定を作成します。
記事中ではOCNバーチャルコネクト向けにスクリプトが書かれているため、一部の値を変更しています。
また、オリジナルにはないのですが、最後にMSSの変更を行うマングル設定を追加しました。

:global addNatRules do={
  # Args: $PSID $v4Addr $outInterface
  :for i from=1 to=15 do={
    :local portStart ((i << 12) | ([:tonum $PSID] << 4))
    :local portEnd   ($portStart + 15)
    :local portRange "$portStart-$portEnd"
    /ip firewall nat add chain="srcnat" action=masquerade protocol=tcp nth="$(16 - $i),1" to-address=$v4Addr to-ports=$portRange out-interface=$outInterface
    /ip firewall nat add chain="srcnat" action=masquerade protocol=udp nth="$(16 - $i),1" to-address=$v4Addr to-ports=$portRange out-interface=$outInterface
  }
}
$addNatRules PSID=<固有値> v4Addr=<割り当てられたIPアドレス> outInterface=ipipv6-v6plus
/ip firewall mangle add action=change-mss chain=forward new-mss=clamp-to-pmtu passthrough=yes protocol=tcp routing-mark=v6plus-route tcp-flags=syn tcp-mss=1460-65535

※設定されるnthの値がおかしい気がするのですが、いったん置いておきます。(ここはオリジナルから変更なし)

結果

いわゆるニチバンベンチをあっさり通過し、キャッシュ無効設定で各種サイトを巡ってもまともに表示されています。
ただ、時間経過や特定のサイトで詰まる可能性はありますので、要経過観察です。
ぬか喜びになりませんように!

なぜうまく動いたのか

実は、参考にさせていただいたブログ記事では、結局うまく行かず別の方式に乗り換えたと書かれています。
そもそもどううまく行かなかったのかが書かれていないので差異を探ることも難しいかなとは思いますが、違いがあるとすればOSのバージョン、パケットを通す通さないのフィルタ設定、私がスクリプトに書き加えたマングル設定でしょうか。
肝となる設定を今後探っていければと思っています。

2021/05/29追記:上述したMSS変更のマングル設定と、ブリッジを使っている場合はファストフォワードを切っておく等の工夫を入れると安定する模様。
2021/05/30追記1:ファストトラックも削除しましょう。
2021/05/30追記2:設定を変更した後にルーターを再起動することが重要で、ファストフォーワードとファストトラックについては有効でも問題ないかもしれません。

いちおう速度も

平日22時台の測定です。
筆者宅はPPPoEでも240Mbps程度と割と速度が出るのですが、それよりは速いですね。

image.png

Why not register and get more from Qiita?
  1. We will deliver articles that match you
    By following users and tags, you can catch up information on technical fields that you are interested in as a whole
  2. you can read useful information later efficiently
    By "stocking" the articles you like, you can search right away
0
Help us understand the problem. What are the problem?