#ruby
#rails
#RubyOnRails
#bootstrap

Rails 5でjQueryを動かす

状況

Rails5.1.4でview中(application.html.erbではない)に記述したjQueryが動作せず、consoleでエラーが吐かれていた。

1. yarnをインストール

brew yarn install

2. jQueryを追加する

yarn add jquery

3. jQueryのバージョンを指定する

Bootstrapを動かすためにはjQueryのバージョンが1.9以上3.0以下でないと怒られるらしい。

package.json
{
  "name": "rails_chap04",
  "private": true,
  "dependencies": {
    "jquery": "^1.9.1"
  }
}

4. application.jsを編集する

Rails5.0ではbootstrapよりも上に記述する!

application.js
//= require jquery
//= require rails-ujs
//= require turbolinks
//= require bootstrap
//= require_tree .

参考資料

こちらの記事を参考にさせていただきましたm(_ _)m
Rails5.1でjQueryを追加する方法