Rails5

railsでサーバー立てようとしたらエラー出た

まじ色々大変だわ

bundlerのrailsのバージョンとrubyのrailsのバージョン違いでは?

rubyのrailsのバージョンをチェック

$ruby -v
 Rails 5.1.4

これに合わせてみた

bundlerの方をチェック

Gemfileのrailsのバージョンを書き換える

gem 'rails', '5.1.4' 

これでもう一回bundle installしてみた

そしたらこんなエラーがでてきた

Could not find gem 'rails (= 5.1.4)'

とりあえず変更したGemfileを元に戻した。そしてもう一度bundle installしたらこんどはこのエラーを発見
An error occurred while installing nio4r (2.1.0), and Bundler cannot continue.
Make sure that gem install nio4r -v '2.1.0' succeeds before bundling.

とりあえず以下のものを試す。

gem install nio4r -v '2.1.0'

エラー出る。

調べてたらみつけた記事に同じようなのが載ってた

この記事ですね。
https://stackoverflow.com/questions/42652189/how-to-fix-a-bundle-install-nio4r-error-on-rails-5-0-0
とりあえずこの記事に従ってやってみる。

消えない、、、泣。