Posted at

bundle updateしたら「Bundler could not find compatible versions for gem "railties":」というエラーメッセージが出たときの対処法。

More than 5 years have passed since last update.

Ruby、Railsの環境設定にてGemfileを設定し、bundle updateのコマンドをうつと以下のエラーがおきました。

Bundler could not find compatible versions for gem "railties":

In Gemfile:
rails (= 4.0.0) ruby depends on
railties (= 4.0.0) ruby

sass-rails (= 4.0.0) ruby depends on
railties (4.0.1.rc3)

この場合はGemfileの設定を見直します。


Gemfile.rb

gem 'sass-rails', '4.0.0'

gem 'coffee-rails', '4.0.0'

上記の行を変更


Gemfile.rb

group :assets do

gem 'sprockets-rails', :git => 'https://github.com/rails/sprockets-rails.git' #追記
gem 'sass-rails', '~> 4.0.0', :git => 'https://github.com/rails/sass-rails.git'
gem 'coffee-rails', '~> 4.0.0', :git => 'https://github.com/rails/coffee-rails.git'
end

bundle updateしてエラーが起きなければ成功。

rails serverも使えると思います。