Linux
Speech
spro

sproのインストール


目的


  • Speech Signal Processing ToolkitのsproをInstallしようとしたらうまく行かなかったので備忘録


ENV


  • Linux

  • spro4.0~


Usage


  • 最新のだと普通にDLしてきてMakeしてもErrorを吐かれる.

  • そのためgccのVersionを古いのに変える

# g++/gccのバージョン確認

$ g++ --version

# aptで手に入る一覧を取得
$ sudo apt-cache search g++ | grep ^g++

# 上記で4.4とか手に入らない場合(Ubuntu)
$ vim /etc/apt/sources.list
# 下記行を追加
deb http://dk.archive.ubuntu.com/ubuntu/ trusty main universe
deb http://dk.archive.ubuntu.com/ubuntu/ trusty-updates main universe

$ sudo apt update
$ sudo apt install g++-4.4

#sproをg++4.4でbuildする
$ cd spro_directory && export CC=gcc-4.4 && ./configure && make
$ sudo make install