PHP
homebrew

サポート終了の PHP を Homebrew で使いたい時

Homebrew では、サポート中の PHP しかインストールできません。

もしもの時に、5.6 や 7.0 などの古いバージョンをインストールしたいときは、exolnet/deprecated を使います。

$ brew tap exolnet/homebrew-deprecated

$ brew install php@5.6
$ brew install php@7.0

ただし PHP5.6 の挙動はあまりよろしくないです。

良い子は、サポート中の PHP しか使っちゃダメですよ。(涙)


クレジット

この記事が役に立ったら、「 CMS は concrete5 が一番」と頭の中で10回唱えてみてください〜。