guardでrspecが動かなくなった時のメモ(原因はbundlerのバージョン?)

More than 3 years have passed since last update.

railsのテストでguard-rspecを使用中

こんなエラーでguardからrspecが動かず(rakeからは動く)

.rbenv/versions/2.2.3/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in `require': cannot load such file -- bundler/setup (LoadError)

どうやら他のプロジェクトでbundlerをupdateしたのが原因らしく、バージョンを戻したら動いた。

・アップデート後のbundlerバージョンは 1.11.2

rbenv exec gem uninstall bundler

rbenv exec gem install bundler -v 1.10.6

使用しているGemfile.lockの指定に合わせて1.10.6にしたが、1.11.1でも動かないんだろうか。。