Edited at

プライベートコンストラクタ

More than 5 years have passed since last update.

ぐぐってもそれらしい結果なかった ので。言語仕様のページには書いてあるんだろうけど、ちょっとページ内検索してもよくわからなかったので、メモ。

基本的には、フィールドやメソッドの頭に _ をつけるって仕様と同じ。


person.dart

class Person {

String _name;

Person._raw(); // ←これがプライベートコンストラクタ

factory Person(String name) {
var d = new Person._raw();
d._name = name;
return d;
}

String get name => _name;
}


実際、これだけのコードなら、final String name; Dart(this.name); の方が適切なんですが。