Posted at

Moodle 3.7 マニュアル - アップグレードFAQ

原文

内容

1 1.9.x から 3.7 にアップグレードするには?

2 Moodle をアップグレードするには? ファイルをただ上書きすべきですか?

3 "Upgrade already running in this session, please wait!" というメッセージが出ます

4 一度に一つ以上のアップグレードが可能ですか

5 カスタムコードがサイトに存在します-どのようにアップグレードしますか?

6 もっと質問がありますか?

7 参照


1 1.9.x から 3.7 にアップグレードするには?

1.x -> 1.9.19+ -> 2.2.11 -> 2.7.20 -> 3.2.9 -> 3.7

(次のブランチに行く前に、最新の安定ブランチにアップグレードすることがよいです。プラグインも同様です。以前の安定ブランチにアップグレードすることは通常はうまくいきますが、保証はありません。)

Moodle 2.2.11 は https://download.moodle.org/stable22/ からダウンロードできるでしょう。


2 Moodle をアップグレードするには? ファイルをただ上書きすべきですか?

ファイルを上書きしてはいけません。 それをすると、奇妙なエラーが発生します。進む前に、アップグレード を読んでください。


3 "Upgrade already running in this session, please wait!" というメッセージが出ます

あなたは、完了メッセージの前に、ページをリフレッシュしたに違いありません。アップグレードプロセス(php と/又は mysql)が実行中でないことを絶対に確信しているのなら、"!!!" をクリックして、アップグレードをリスタートできます。

注:もしあなたが、"'!!!" をクリックするかまたは別のブラウザでアップグレードをリスタートするのなら、あなたのデータベースのデータが壊れる可能性があります。もしそれが起これば、sql ダンプからデータベースをリストアする必要があり、アップグレードをリスターとして待つ - このプロセスは、大規模なサイトならば、数時間はかかります - 必要があります。


4 一度に一つ以上のアップグレードが可能ですか

Moodle 3.7 にアップグレードできるのは、Moodle 3.2 あるいはそれ以上からのみです。

Moodle 2.7 にアップグレードできるのは、Moodle 2.2 あるいはそれ以上からのみです。

Moodle 2.2 にアップグレードできるのは、Moodle 1.9 あるいはそれ以上からのみです。


5 カスタムコードがサイトに存在します どのようにアップグレードしますか?

さらなる忠告は、upgrading with custom code についてのフォーラムの投稿を参照してください。


6 もっと質問がありますか?

moodle.org の Installing and upgrading help forum で質問してください。


7 参照

インストールFAQ

カテゴリ:インストール FAQ