Redmine
Plugin
BITNAMI
projectmanagement

Bitnami Redmineでredmine_vividtone_my_page_blocks-master installのPluginをやってみた結果インスコできなかった+インスコできたけど使えなかったを記録

1回目トライ@Oct 16, 2015

Pluginは、Clipboard image paste, Redirect to url after login, Absolute Dates, Issue Templates, Local Avatars・・と続きこれで6つ目、優先して処理すべきチケットを色違いなどで表示できる・・というのを期待でインスコ

redmine_vividtone_my_page_blocks-master

・・をGitからZIPでDLしファイルを解凍

フォルダ名末尾”-master”は削除・・が常識なのでフォルダ名を変更して

c:\bitnami\redmine2.6-1.0\apps\redmine\htdocs\pluginsにフォルダごと置いて

cd C:\Bitnami\redmine-2.6.1-0\apps\redmine\htdocs

htdocs>bundle exec rake redmine:plugins:migrate RAILS_ENV=production

DL is deprecated, please use Fiddle
rake aborted!

が返るが、ほんとこの「DLは非難、Fiddle使って、rakeを中絶!」って毎々何だ?・・と改めてムカつくがTemplate pluginに調べたのを載せているのでそちらを振り返り

・・で更にメッセージが返って

Redmine::PluginRequirementError: redmine_vividtone_my_page_blocks plugin require
s Redmine 3.0.0 or higher but current is 2.6.1.stable

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/lib/redmine/plugin.rb:205:in 'block in requires_redmine'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/lib/redmine/plugin.rb:200:in 'each'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/lib/redmine/plugin.rb:200:in 'requires_redmine'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/plugins/redmine_vividtone_my_page_blocks/init.rb:4:in 'block in '

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/lib/redmine/plugin.rb:75:in 'instance_eval'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/lib/redmine/plugin.rb:75:in 'register'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/plugins/redmine_vividtone_my_page_blocks/init.rb:3:in ''

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/vendor/bundle/ruby/2.0.0/gems/activesupport-.2.21/lib/active_support/dependencies.rb:251:in 'require'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/vendor/bundle/ruby/2.0.0/gems/activesupport-.2.21/lib/active_support/dependencies.rb:251:in 'block in require'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/vendor/bundle/ruby/2.0.0/gems/activesupport-.2.21/lib/active_support/dependencies.rb:236:in 'load_dependency'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/vendor/bundle/ruby/2.0.0/gems/activesupport-.2.21/lib/active_support/dependencies.rb:251:in 'require'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/lib/redmine/plugin.rb:150:in 'block in load'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/lib/redmine/plugin.rb:141:in 'each'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/lib/redmine/plugin.rb:141:in 'load'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/config/initializers/30-redmine.rb:19:in ''

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/vendor/bundle/ruby/2.0.0/gems/activesupport-.2.21/lib/active_support/dependencies.rb:245:in 'load'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/vendor/bundle/ruby/2.0.0/gems/activesupport-.2.21/lib/active_support/dependencies.rb:245:in 'block in load'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/vendor/bundle/ruby/2.0.0/gems/activesupport-.2.21/lib/active_support/dependencies.rb:236:in 'load_dependency'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/vendor/bundle/ruby/2.0.0/gems/activesupport-.2.21/lib/active_support/dependencies.rb:245:in 'load'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/vendor/bundle/ruby/2.0.0/gems/railties-.2.21/lib/rails/engine.rb:593:in 'block (2 levels) in class:Engine'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/vendor/bundle/ruby/2.0.0/gems/railties-.2.21/lib/rails/engine.rb:592:in 'each'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/vendor/bundle/ruby/2.0.0/gems/railties-.2.21/lib/rails/engine.rb:592:in 'block in class:Engine'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/vendor/bundle/ruby/2.0.0/gems/railties-.2.21/lib/rails/initializable.rb:30:in 'instance_exec'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/vendor/bundle/ruby/2.0.0/gems/railties-.2.21/lib/rails/initializable.rb:30:in 'run'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/vendor/bundle/ruby/2.0.0/gems/railties-.2.21/lib/rails/initializable.rb:55:in 'block in run_initializers'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/vendor/bundle/ruby/2.0.0/gems/railties-.2.21/lib/rails/initializable.rb:54:in 'each'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/vendor/bundle/ruby/2.0.0/gems/railties-.2.21/lib/rails/initializable.rb:54:in 'run_initializers'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/vendor/bundle/ruby/2.0.0/gems/railties-.2.21/lib/rails/application.rb:136:in 'initialize!'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/vendor/bundle/ruby/2.0.0/gems/railties-.2.21/lib/rails/railtie/configurable.rb:30:in 'method_missing'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/config/environment.rb:14:in ''

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/vendor/bundle/ruby/2.0.0/gems/activesupport-.2.21/lib/active_support/dependencies.rb:251:in 'require'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/vendor/bundle/ruby/2.0.0/gems/activesupport-.2.21/lib/active_support/dependencies.rb:251:in 'block in require'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/vendor/bundle/ruby/2.0.0/gems/activesupport-.2.21/lib/active_support/dependencies.rb:236:in 'load_dependency'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/vendor/bundle/ruby/2.0.0/gems/activesupport-.2.21/lib/active_support/dependencies.rb:251:in 'require'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/vendor/bundle/ruby/2.0.0/gems/railties-.2.21/lib/rails/application.rb:103:in 'require_environment!'

C:/Bitnami/redmine-2.6.1-0/apps/redmine/htdocs/vendor/bundle/ruby/2.0.0/gems/railties-.2.21/lib/rails/application.rb:305:in block (2 levels) in initialize_tasks'

Tasks: TOP => redmine:plugins:migrate => environment
(See full trace by running task with --trace)

・・でエラー(らしき)が続き敢え無く断念

2回目トライ@Oct 30, 2015

GitからDLし直しフォルダ名は-masterを削除して

c:\bitnami\redmine2.6-1.0\apps\redmine\htdocs\plugins
にフォルダごと置く

cd C:\Bitnami\redmine-2.6.1-0\apps\redmine\htdocs

bundle exec rake redmine:plugins:migrate RAILS_ENV=production

rake aborted!
Redmine::PluginRequirementError: redmine_vividtone_my_page_blocks plugin require
s Redmine 3.0.0 or higher but current is 2.6.1.stable

・・・・・・

で同様エラー続き、またまた断念

そもそも「このpluginはRedmine 3.0.0以上を要求、なのに現状お前は2.6.1」と言っているのでDLした物がマズイ、という結論に

3回目トライは旧ver1.2@Dec 21, 2015

前回はrake aborted!
Redmine::PluginRequirementError: redmine_vividtone_my_page_blocks plugin require
s Redmine 3.0.0 or higher but current is 2.6.1.stable
・・・で、はじかれたので今回は敢えて古いだろう以下で再チャレンジ

redmine_vividtone_my_page_blocks-1.2.zip

zip解凍後-masterを削除しフォルダごと置いてhtdocsで

bundle exec rake redmine:plugins:migrate RAILS_ENV=production

DL is deprecated, please use Fiddle

Migrating clipboard_image_paste (Clipboard image paste)...

Migrating redirect_to_after_login (Redmine Redirect to url after login Plugin)...

Migrating redmine_absolute_dates (Redmine Absolute Dates plugin)...

Migrating redmine_issue_templates (Redmine Issue Templates plugin)...

Migrating redmine_local_avatars (Redmine Local Avatars plugin)...

Migrating redmine_vividtone_mypage_blocks (My Page Blocks plugin)...

・・・って通った感じ。

単に最新版は最新Redmine3.0対応、旧verには使えないということだったようで。

ここでRedmineのPluginってのは

最新だからってインスコできないあり。GitのInstallation注意書きをよく見るべき? まあOSへアプリインスコと思えば同じか。WebアプリへのAdd-onだが適用できるverは何かを事前しっかり確認(王道ルール)。

またMigration結果を見ると今までのPluginを再実施している・・・

Clipboard image paste, Redirect to url after login, Absolute Dates, Issue Templates, Local Avatars,と そして今回入れようとしているMy Page Blocks・・

RedmineのPluginインスコってのはこういうことなんだ。まあ、複数モジュール/ページで構成されるRedmineの全ソースに反映するんだから当然といえば当然か・・

でも結局使えない

Thin_redmine, Thin_redmine2ともRestartはOK

管理>プラグイン、を見るとMy Page Blocks pluginあるじゃない・・でvividtoneはインスコされた。  →^_^;

My Pageからパーソナライズを選択しプルダウンにDoing Issue、Neglected Issuesが表示され選択する

が・・・その後、404エラー(愕然!!)

直前のredirect_to_after_loginとのコンフリクト??

と思いredirectをpluginフォルダから除いてRestart
してもMy Pageで404エラーは変わらず

結局vividtone_my_page_blocksをPluginフォルダからdeleteしredirectを戻してRestartで無かったことに

このvividtoneは最新は3.0じゃないとダメだし、1.2でもダメダメだし、もう二度と使わない。