phpbrew install で Please reinstall the BZip2 distributionと出た時の対処法

phpの環境構築をしていた時に

phpbrew install 5.6.23 +default +mysql  +openssl=$(brew --prefix openssl)

=> configure: error: Please reinstall the BZip2 distribution

のようなエラーが出たので、解決策を書いておきます。

解決策

xcode-select --install

これだけで解決します。

解説

上記のエラーはbzip2というものが、ないぞ!ってエラーなので、入れてあげつ必要があります。

bzip2とは何かの解説wiki

bzip2はもともとmacのOSに入っているものなので、

xcode-select --install

でインストールすることができます。
ちなみにこのコマンドはXcodeのコマンドラインツールをインストールするためのコマンドらしい

参考サイト

Sign up for free and join this conversation.
Sign Up
If you already have a Qiita account log in.