vagrant

Vagrant1.5.1へのアップグレード後にvagrant upに失敗する場合の直し方

More than 3 years have passed since last update.


現象

以下のエラーが発生する。

in initialize': Malformed version number string virtualbox (ArgumentError)


直し方

$ echo "1.1" > ~/.vagrant.d/setup_version

$ vagrant up
Vagrant is upgrading some internal state for the latest version.
Please do not quit Vagrant at this time. While upgrading, Vagrant will need to copy all your boxes, so it will use a considerable amount of disk space. After it is done upgrading, the temporary disk space will be freed.

このあと滅茶苦茶待たされた。(5分くらい)

https://github.com/mitchellh/vagrant/issues/3195