MAMPのUIからの設定だとだいたい2バージョンくらいしか指定できない。
デプロイ先のサーバーの都合によりそれ以外のPHPに変えたい時の設定方法。
(phpenvはやってない)

Macの時はapacheのconfは
/Application/MAMP/conf/apache/httpd.conf
で、このファイルを編集する。

このファイルの100行目近辺にLoadModuleの記載があるので、PHPのモジュールを読み込んでいるところを変更する。
例)
LoadModule php7_module /Applications/MAMP/bin/php/php7.2.1/modules/libphp7.so

LoadModule php5_module /Applications/MAMP/bin/php/php5.6.10/modules/libphp5.so

とか、変更後Apache再起動でOK

MAMPにバンドルされてるPHPはMAMP以下のbin/phpの中にあるので、その中から使いたいバージョンを指定しよう。

Sign up for free and join this conversation.
Sign Up
If you already have a Qiita account log in.