Posted at

pip installの際に依存ライブラリを入れたくない


困っていた状況

あるライブラリ(polytester)を導入する必要があるのだが、requirements.txtに記載されている

PyYAML==3.11

がエラーを起こすためにインストールできなかった。コマンドラインから試したところ、最新の3.13なら問題なくインストールできることがわかった。

requirements.txtを書き換えればインストールできるがそれは避けたい。


解決方法

requirements.txtに以下を記載

--install-option --no-deps polytester==1.2.0

--no-depsで依存ライブラリを自動的に取り込まなくなるのでrequirements.txtに以下を追記

PyYAML==3.13

clint==0.4.1
watchdog==0.8.2