Ruby
Rails
bundler

Your Ruby version is 2.3.7, but your Gemfile specified 2.6.3


rbenvを使用してRubyをインストールする

参考サイト

https://qiita.com/Alex_mht_code/items/d2db2eba17830e36a5f1


bash_profileを編集してRubyのバージョンを切り替える

参考サイト

https://qiita.com/opiyo_taku/items/3312a75d5916f6cd32b1


それでも解決しない場合(ボクはこれで解決した)

bundle exec rails db:create    ///データベースを作成

bundle exec rails db:migrate ///データベースにテーブルを作成

bundle exec rails s ///webサーバーを起動