Linux
Ubuntu
apt-get

UbuntuにおけるAPTのエラー

More than 1 year has passed since last update.

linux-serverを更新しようとしてエラー

普通にパッケージをインストールしようとするとエラーになる。
なので、

# apt-get -f install

を実行すると、

dpkg: 依存関係の問題により linux-server の設定ができません:
linux-server は以下に依存 (depends) します: linux-image-server (= 3.2.0.82.96) ...しかし:
システム上の linux-image-server のバージョン は 3.2.0.87.101 です。
linux-server は以下に依存 (depends) します: linux-headers-server (= 3.2.0.82.96) ...しかし:
システム上の linux-headers-server のバージョン は 3.2.0.87.101 です。
dpkg: linux-server の処理中にエラーが発生しました (--configure):
依存関係の問題 - 設定を見送ります

というエラーで怒られる。
なんで、linux-serverのバージョンが3.2.0.87.96なのに、linux-image-serverと、linux-headers-serverのバージョンが3.2.0.87.101なんだよ………。

しょうがないので、Ubuntuのサイトから3.2.0.87.96のlinux-image-serverと、linux-headers-serverを落としてきて、

# dpkg -i パッケージ名

でインストールして、再び apt-get -f install してやったら無事解決。
入れようと思ってたパッケージのインストールも出来た。