Posted at

OS X Yosemiteで`You have to install development tools first.`と言われnokogiriのインストールに失敗する場合

More than 5 years have passed since last update.



  1. apple-gcc42がインストールされていればアンインストール

  2. rbenvでrubyを再インストール

$ brew uninstall apple-gcc42

$ rbenv uninstall 2.1.2
$ rbenv install 2.1.2

https://github.com/sparklemotion/nokogiri/issues/1111#issuecomment-48018063