More than 1 year has passed since last update.

(インストールしている状態で停止するので「YARNが止まる」の方が適切だったか…?)

YARNを初めて使ったらインストールでつまずいたのでメモ。

$ yarn
yarn install v0.17.8
info No lockfile found.
[1/4] 🔍  Resolving packages...
warning babel@6.3.26: Babel's CLI commands have been moved from the babel package to the babel-cli package
warning debowerify > bower > glob > minimatch@1.0.0: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
warning browser-sync > resp-modifier > minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
warning debowerify > bower > bower-config > graceful-fs@2.0.3: graceful-fs v3.0.0 and before will fail on node releases >= v7.0. Please update to graceful-fs@^4.0.0 as soon as possible. Use 'npm ls graceful-fs' to find it in the tree.
warning debowerify > bower > insight > tough-cookie@0.12.1: ReDoS vulnerability parsing Set-Cookie https://nodesecurity.io/advisories/130
warning debowerify > bower > request > node-uuid@1.4.7: use uuid module instead
warning browser-sync > localtunnel > request > node-uuid@1.4.7: use uuid module instead
warning debowerify > bower > update-notifier > latest-version > package-json > registry-url > npmconf@2.1.2: this package has been reintegrated into npm and is now out of date with respect to npm
[2/4] 🚚  Fetching packages...
██████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████ 931/932

931/932の状態で進展なし。

使ってたNodeのバージョンが6.0.0だったのですが、v6.9.1(LTS)に上げたら解決。

nvm使ってる場合は

$ nvm install 6.9.1
$ nvm alias default 6.9.1
$ npm install -g yarn

でOK。

YARNデビューしました。

Sign up for free and join this conversation.
Sign Up
If you already have a Qiita account log in.