1. bellx2

    No comment

    bellx2
Changes in body
Source | HTML | Preview

Chromeで「SSL サーバーが古い可能性があります」と出てアクセスできない現象が発生すると言われて調査したのでまとめておきます。

スクリーンショット 2015-09-04 23.27.20.png

2015/9/3にstableでリリースされたChrome v.45(OSX/Windows)からアクセスできなくなったようで、ちなみにIEやFirefox、Safariからだと問題無く見れているようです。

原因

SSL3.0の脆弱性(POODLE)対策として実施されています。サーバー管理者はサーバー側で対策、クライアント側はブラウザーでSSL3を使わないような設定をするように告知されています。ブラウザ側での標準対応が進み、サーバー側で対策をしていない場合は警告表示が出てくるようになりました。

調査方法

以下のサイトでSSLの有効状況を調査する事ができます。
https://www.ssllabs.com/ssltest/

画像のようにSSL3.0が有効になっている場合に「SSLサーバーが古い可能性があります」と表示されてアクセスできなくなります(Chrome)。

ssl3.jpg

対応方法

サーバー管理者がSSL3.0を無効にする必要があります。利用者側で回避はできないみたいですので、警告の出ないIEを利用してください。

Windows IIS

https://technet.microsoft.com/ja-jp/library/security/3009008.aspx

Apache (Linux)

/etc/httpd/conf.d/ssl.conf のSSLProtocolを変更します(mod_ssl)

/etc/httpd/conf.d/ssl.conf
SSLProtocol All -SSLv2 -SSLv3

※SSL2.0 3.0以外は全て使う設定

参考

IPAからでている以下の情報が良くまとまっています。

SSL 3.0 の脆弱性対策について(CVE-2014-3566)

ぶつぶつ

クロネコの再配達ページの管理者様早くなおしてあげてください!