Facebook
Unity

Unity Facebook連携 SDK 7.11がiosビルド通らなかった

More than 1 year has passed since last update.

環境はUnity2017.3.0f1

OSはMac Sierra

Xcode 9.2

Facebook SDKをUnityに入れようと思ったら

AssetStoreのFacebook SDKがどうも3年前ので怪しい。

レビューも古いってあって・・・。

AssetStoreのやつのバージョンは7.2.2

そして設定画面もなんだかちゃんと項目が表示されてなかったりで・・・。

なので公式サイトからSDKをダウンロード

バージョンは7.11.0

iosでのビルドでxcodeにてエラーがなかなか解決できずに苦労した

まず大量のiosのバージョン8にしてねってエラーが出てたのでターゲットのiosの最低バージョンを8に。

bitcodeがどうたらーってでてたのでNoに

スクリーンショット 2018-02-26 23.08.57.png

ここまではいいのですが、そのあとこのエラーでハマる。

face3.png

この辺まで行くとgoogle先生も英語のやつしか出してくれないので

翻訳を駆使しながら・・・・

ここ

バグで上がってた。

ここのchamnassi2 さんの書き込みの一時ファイルをダウンロード

Facebook.Unity.dll

ファイルをダウンロードしたものと差し替えたら動きました。

きっといずれは対応してくれると思うけど。

結構ハマったので残しとく。