1. YuukiMiyoshi

    Posted

    YuukiMiyoshi
Changes in title
+Nodenv環境のインストール可能バージョンを更新する
Changes in tags
Changes in body
Source | HTML | Preview
@@ -0,0 +1,46 @@
+## はじめに
+
+Nodenvのインストールや簡単な使い方については、[以前の投稿][1]をご参照ください。
+
+久しぶりにフロント周りのコードを触る用事があり、一年ほど前にインストールしてあったNodenvで環境を作ろうとしたところ、インストール可能バージョンが「8.5」まででした。インストール可能バージョンのリストを更新するにはプラグインの追加が必要で、後々忘れそうなのでメモしておきます。
+
+[1]:https://qiita.com/YuukiMiyoshi/items/080b6cde332d8d4e06f3 "Nodenv環境を用意する"
+
+## 方法
+
+[前出の記事][1]と同じ感覚で更新用プラグインをインストールします。
+(nodenvのインストール先は[~/.nodenv]を想定しています)
+詳細は[プラグインのサイト][2]をご参照ください。
+(上記サイトではgithubへの接続がhttps://となっていますが、本記事では「はじめに」で紹介した[前記事][1]に合わせてgit://にしています)
+
+[2]:https://github.com/nodenv/node-build-update-defs "node-build-update-defs"
+
+次のコマンドでNodenvへプラグインをインストールします。
+
+```{sh}
+git clone git://github.com/nodenv/node-build-update-defs.git ~/.nodenv/plugins/node-build-update-defs
+```
+
+次のコマンドでインストール可能バージョンのリストを更新します
+
+```{sh}
+nodenv update-version-defs
+```
+
+## 確認
+
+次のコマンドで、インストール可能バージョンを確認します
+
+```{sh}
+nodenv install --list
+(省略)
+ 9.8.0
+ 9.9.0
+ 9.10.0
+ 9.10.1
+ 9.11.0
+ 9.11.1
+(省略)
+```
+
+無事に更新されました!