puma gemがインストールできない

  • 2
    いいね
  • 0
    コメント
この記事は最終更新日から1年以上が経過しています。

問題

/usr/bin/ruby2.2 -r ./siteconf20151006-20026-1jihocl.rb extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

といったエラーがでてPumaがインストールできない。(Ubuntu)

解決法

ruby-devruby(バージョン)-devをインストールする。

sudo apt-get install ruby-dev ruby2.2-dev
というように。

(rbenvのruby(バージョン)-devとapt-getのruby(バージョン)-devは異なるので注意。)