An error occurred while installing rmagick

  • 0
    いいね
  • 0
    コメント
    
    An error occurred while installing rmagick (2.16.0), and Bundler cannot
    continue.
    Make sure that `gem install rmagick -v '2.16.0'` succeeds before bundling.
    
    
    

    怒られた。

    調べると7系はダメで6系をじゃないとダメみたい。

    
    brew uninstall imagemagick
    
    
    brew unlink imagemagick
    
    
    

    で既存のrmagickをアンインストール

    リポジトリを指定してインストール

    
    brew install https://raw.githubusercontent.com/Homebrew/homebrew-core/6f014f2b7f1f9e618fd5c0ae9c93befea671f8be/Formula/imagemagick.rb