`apt-get install`するまえに`apt-cache` でバージョンを調べる方法

  • 37
    いいね
  • 0
    コメント
この記事は最終更新日から1年以上が経過しています。

UbuntuにGimpを入れようと思ったけど、入れる前に2.6が入るのか2.8が入るのか知りたかったので
apt-cache search gimp してみたけどバージョン名が出てこない。

解決策

apt-cache policy gimp

すると見れる。こんな感じの出力

$ apt-cache policy gimp
gimp:
  インストールされているバージョン: (なし)
  候補:               2.6.12-1ubuntu1.2
  バージョンテーブル:
     2.6.12-1ubuntu1.2 0
        500 http://jp.archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
        500 http://security.ubuntu.com/ubuntu/ precise-security/main i386 Packages
     2.6.12-1ubuntu1 0
        500 http://jp.archive.ubuntu.com/ubuntu/ precise/main i386 Packages

ついでにGimp 2.8 をインストール方法も調べときました。

apt-get で Gimp2.8をUbuntuにインストールする方法 - Qiita [キータ]
http://qiita.com/ironsand/items/c330276242347784dc70

参考

debian - How to check the version before install packages using apt-get - Stack Overflow
http://stackoverflow.com/questions/18885820/how-to-check-the-version-before-install-packages-using-apt-get