MacでEclipseのインストール

  • 3
    いいね
  • 0
    コメント
この記事は最終更新日から1年以上が経過しています。

Eclipseダウンロード

Eclipseのダウンロードページからダウンロードしてきます。
ダウンロードしたファイルを解凍して開くと以下エラーがでました。

Javaランタイムをインストールする必要があります。

うんたらかんたらと書いていたので詳細のリンクからJREをインストールしました。
MacデフォルトではJREはインストールされていないんですね。

再度解凍したファイルを開こうとしたら以下のエラーがでました。

Incompatible JVM.png

Version1.6.0_65 of the JVM is not suitable for this product.
Version: 1.7 or greater is required.

内容としては
「JVMのバージョンがEclipseと適してないです。
1.7以上のバージョンにしてください。」

ターミナルからjava -versionでバージョン確認できます。

JDKダウンロード

MacはデフォルトのJDKが使用されるので新しいバージョンのJDKが必要です。
ということで、JDKをOracleのJavaSEダウンロードページからダウンロードしました。

ダウンロード.png

アイコンをダブルクリックしてインストールします。
インストール完了後、ターミナルを再起動して
java -versionを実行するとインストールしたJavaのバージョンが表示されて確認できました。

Eclipse起動確認して完了。

以上