Gradle3.4のIDEプラグインがバグっていてIntelliJでデバッグが不可になる

  • 5
    いいね
  • 1
    コメント

現象

この不具合は、Gradle3.4にて発生する。

IntelliJ(等 ScopeをサポートしているIDE)でGradleプロジェクトのDependencyを読み込むと、compileスコープで設定しているはずのDependencyがProvidedとして読み込まれるなどして、実行/デバッグ時にJarが見つからない不具合が起きる。

対処方法

Gralde 3.3以下を使う。またはバグの修正を待つ。

参考